[package] dnsmasq: if CONFIG_IPV6 is off, compile with -DNO_IPV6 - solves unresolved...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Jan 2012 19:00:53 +0000 (19:00 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Jan 2012 19:00:53 +0000 (19:00 +0000)
SVN-Revision: 29777

package/dnsmasq/Makefile

index a2084a616cdd79d3a9dbbcd80fc209983d97e325..a23e9ff795232cffa3cf02c4b5755b62bb9d799b 100644 (file)
@@ -35,7 +35,9 @@ define Package/dnsmasq/conffiles
 /etc/dnsmasq.conf
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_CFLAGS += \
+       -ffunction-sections -fdata-sections \
+       $(if $(CONFIG_IPV6),,-DNO_IPV6)
 
 MAKE_FLAGS := \
        $(TARGET_CONFIGURE_OPTS) \