Install libuci and headers in staging_dir
authorAndy Boyett <agb@openwrt.org>
Fri, 4 Apr 2008 21:48:43 +0000 (21:48 +0000)
committerAndy Boyett <agb@openwrt.org>
Fri, 4 Apr 2008 21:48:43 +0000 (21:48 +0000)
SVN-Revision: 10732

package/uci/Makefile

index 54d01c15894676e002d7031debaa989492907cf5..41430f7e144c9b8200c1d53fff2f25f644d23fd6 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -73,6 +73,13 @@ define Package/uci-sh/install
        $(CP) ./files/uci-sh/* $(1)/
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
+endef
+
 $(eval $(call BuildPackage,uci))
 $(eval $(call BuildPackage,libuci))
 $(eval $(call BuildPackage,uci-sh))