Add libogg, libvorbis and libtheora packages.
authorLars-Peter Clausen <lars@metafoo.de>
Wed, 10 Sep 2008 17:14:05 +0000 (17:14 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Wed, 10 Sep 2008 17:14:05 +0000 (17:14 +0000)
SVN-Revision: 12565

libs/libogg/Makefile [new file with mode: 0644]
libs/libtheora/Makefile [new file with mode: 0644]
libs/libvorbis/Makefile [new file with mode: 0644]

diff --git a/libs/libogg/Makefile b/libs/libogg/Makefile
new file mode 100644 (file)
index 0000000..f3ca350
--- /dev/null
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libogg
+PKG_VERSION:=1.1.3
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ogg/
+PKG_FIXUP:=libtool
+PKG_MD5SUM:=eaf7dc6ebbff30975de7527a80831585
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL=1
+
+define Package/libogg
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=libogg
+  URL:=http://xiph.org/ogg/
+endef
+
+define Package/libogg/description
+Ogg project codecs use the Ogg bitstream format to arrange the raw,
+compressed bitstream into a more robust, useful form.  For example,
+the Ogg bitstream makes seeking, time stamping and error recovery
+possible, as well as mixing several sepearate, concurrent media
+streams into a single physical bitstream.
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/ogg/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/ogg/* $(1)/usr/include/ogg/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,la} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DIR) $(1)/usr/share/aclocal/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
+endef
+
+define Package/libogg/install
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a} $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libogg))
diff --git a/libs/libtheora/Makefile b/libs/libtheora/Makefile
new file mode 100644 (file)
index 0000000..47a9238
--- /dev/null
@@ -0,0 +1,63 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libtheora
+PKG_VERSION:=1.0beta3
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/theora/
+PKG_FIXUP:=libtool
+PKG_MD5SUM:=04b3e1055da49daba6afce93f3214b1f
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL=1
+
+define Package/libtheora
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=libtheora
+  URL:=http://xiph.org/theora/
+  DEPENDS:=+libogg
+endef
+
+define Package/libtheora/description
+Theora is Xiph.Org's first publicly released video codec, intended
+for use within the Foundation's Ogg multimedia streaming system.
+Theora is derived directly from On2's VP3 codec; Currently the
+encoders are nearly identical, but Theora will make use of new
+features supported by the decoder to improve over what is
+is possible with VP3.
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --disable-examples \
+               --disable-oggtest \
+               --disable-vorbistest \
+               --disable-sdltest \
+       )
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/theora/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/theora/* $(1)/usr/include/theora/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,la} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libtheora/install
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a} $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libtheora))
diff --git a/libs/libvorbis/Makefile b/libs/libvorbis/Makefile
new file mode 100644 (file)
index 0000000..6aabc87
--- /dev/null
@@ -0,0 +1,64 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libvorbis
+PKG_VERSION:=1.2.0
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/vorbis/
+PKG_MD5SUM:=478646358c49f34aedcce58948793619
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL=1
+
+define Package/libvorbis
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=libvorbis
+  URL:=http://xiph.org/vorbis/
+  DEPENDS:=+libogg
+endef
+
+define Package/libvorbis/description
+Vorbis is a general purpose audio and music encoding format
+contemporary to MPEG-4's AAC and TwinVQ, the next generation beyond
+MPEG audio layer 3. Unlike the MPEG sponsored formats (and other
+proprietary formats such as RealAudio G2 and Windows' flavor of the
+month), the Vorbis CODEC specification belongs to the public domain.
+All the technical details are published and documented, and any
+software entity may make full use of the format without license
+fee, royalty or patent concerns.
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --disable-oggtest \
+       )
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/vorbis/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/vorbis/* $(1)/usr/include/vorbis/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,la} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DIR) $(1)/usr/share/aclocal/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
+endef
+
+define Package/libvorbis/install
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a} $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libvorbis))