ignore dependencies when using QUILT
authorFelix Fietkau <nbd@openwrt.org>
Mon, 30 Jul 2007 21:30:18 +0000 (21:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 30 Jul 2007 21:30:18 +0000 (21:30 +0000)
SVN-Revision: 8244

include/subdir.mk

index 4348c7b93d8b4f85734036d058b0c01c1988e2b3..e985c30ff0f3dd632a835fec227d820c0b67c62d 100644 (file)
@@ -23,7 +23,7 @@ define subdir
   $(foreach bd,$($(1)/builddirs),
     $(call warn,$(1),d,BD $(1)/$(bd))
     $(foreach target,$(SUBTARGETS),
-      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
+      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
                +$$(MAKE) -j1 -C $(1)/$(bd) $(target)
         $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))