add missing pg_config.h header to staging_dir, required to build php5 extension
authorNicolas Thill <nico@openwrt.org>
Tue, 23 Aug 2005 15:17:15 +0000 (15:17 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 23 Aug 2005 15:17:15 +0000 (15:17 +0000)
SVN-Revision: 1737

openwrt/package/postgresql/Makefile

index 1f37bb75278df50c20049aa2d1eb3922a06feab2..d83f1afb856e3780fbc34459fa3d78ab9aa77486 100644 (file)
@@ -97,6 +97,7 @@ $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(STAGING_DIR)/usr/include/
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
@@ -109,6 +110,7 @@ uninstall-dev:
        rm -rf \
                $(STAGING_DIR)/usr/include/libpq \
                $(STAGING_DIR)/usr/include/libpq-fe.h \
+               $(STAGING_DIR)/usr/include/pg_config.h \
                $(STAGING_DIR)/usr/include/postgres_ext.h \
                $(STAGING_DIR)/usr/include/postgresql \
                $(STAGING_DIR)/usr/lib/libpq.{a,so*} \