brcm63xx: Add DT support for 96338GW
authorJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:25:22 +0000 (12:25 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:25:22 +0000 (12:25 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42733

target/linux/brcm63xx/dts/bcm96338GW.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/profiles/01-generic.mk

diff --git a/target/linux/brcm63xx/dts/bcm96338GW.dts b/target/linux/brcm63xx/dts/bcm96338GW.dts
new file mode 100644 (file)
index 0000000..2040e2f
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6338.dtsi"
+
+/ {
+       model = "Broadcom BCM96338GW reference board";
+       compatible = "brcm,bcm96338gw", "brcm,bcm6338";
+};
index 5033e3e84ab06847346b92cb8a80da78d4bf6c8f..c7e7978b2829d129fa5e99bcd2e9fbb7a8fbb96e 100755 (executable)
@@ -234,7 +234,6 @@ endef
 define Image/Build
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
        # Various routers
-       $(call Image/Build/CFE,$(1),6338GW,6338,6338GW-generic,,)
        $(call Image/Build/CFE,$(1),6338W,6338,6338W-generic,,)
        $(call Image/Build/CFE,$(1),96358VW,6358,96358VW-generic)
        $(call Image/Build/CFE,$(1),96358VW2,6358,96358VW2-generic)
@@ -334,6 +333,8 @@ $(eval $(call CfeImageDTB,963281TAN,bcm963281TAN,963281TAN,6328,963281TAN-16M-fl
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-4M-flash-generic,,--pad 2))
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-8M-flash-generic,,--pad 4))
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-16M-flash-generic,,--pad 8))
+# Generic 96338GW
+$(eval $(call CfeImageDTB,96338GW,bcm96338GW,6338GW,6338,96338GW-generic))
 # Generic 96345GW2
 $(eval $(call CfeImageDTB,96345GW2,bcm96345GW2,96345GW2,6345,96345GW2-generic))
 $(eval $(call CfeImageDTB,96345GW2,bcm96345GW2,96345GW2,6345,96345GW2-bc221,,--layoutver 5))
index efcd42b6bff2a9c99baafb4f36c79a013a94c5cf..30a17ab2d37301df4fbfb4dff85ab36f668bfa36 100644 (file)
@@ -23,6 +23,15 @@ define Profile/96328avng/Description
 endef
 $(eval $(call Profile,96328avng))
 
+define Profile/96338GW
+  NAME:=Generic 96338GW
+  PACKAGES:=
+endef
+define Profile/96338GW/Description
+  Package set optimized for 96338GW.
+endef
+$(eval $(call Profile,96338GW))
+
 define Profile/96345GW2
   NAME:=Generic 96345GW2
   PACKAGES:=