adds check package
authorJohn Crispin <john@openwrt.org>
Mon, 9 Jun 2008 20:15:26 +0000 (20:15 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 9 Jun 2008 20:15:26 +0000 (20:15 +0000)
SVN-Revision: 11417

libs/check/Makefile [new file with mode: 0644]

diff --git a/libs/check/Makefile b/libs/check/Makefile
new file mode 100644 (file)
index 0000000..2af107b
--- /dev/null
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=check
+PKG_VERSION:=0.9.5
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://dl.sourceforge.net/sourceforge/check/
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include/ -I$(STAGING_DIR)/usr/lib/libiconv/include/ -fPIC
+EXTRA_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/libintl/lib/ -L$(STAGING_DIR)/usr/lib/libiconv/lib/
+
+define Package/check
+  SECTION:=lib
+  CATEGORY:=Libraries
+  TITLE:=check
+  URL:=http://sf.net
+  DEPENDS:=+libxml2
+endef
+
+define Package/check/description
+  unit testinglibrary
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); \
+               if [ -x $(CONFIGURE_CMD) ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+                       $(CONFIGURE_VARS) \
+                       $(CONFIGURE_CMD) \
+                       $(CONFIGURE_ARGS) ;\
+               fi \
+       )
+endef
+
+define Build/Compile
+       cd $(PKG_BUILD_DIR) ; DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) all install
+       cd $(PKG_INSTALL_DIR)/usr/lib/ ; ln -s libcheck.so libcheck_pic.so
+endef
+
+define Build/InstallDev
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+define Package/check/install
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+$(eval $(call BuildPackage,check))