iptables: fix rebuild errors on configuration changes
authorFelix Fietkau <nbd@openwrt.org>
Mon, 18 Jan 2016 13:21:32 +0000 (13:21 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 18 Jan 2016 13:21:32 +0000 (13:21 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48314

package/network/utils/iptables/Makefile

index 626b2527619602a50e2df6df64fb466f8d9b578e..e5bca40c7ee7464514e35f4568026c18319245b3 100644 (file)
@@ -448,6 +448,20 @@ MAKE_FLAGS := \
        KBUILD_OUTPUT="$(LINUX_DIR)" \
        BUILTIN_MODULES="$(patsubst ip6t_%,%,$(patsubst ipt_%,%,$(patsubst xt_%,%,$(IPT_BUILTIN) $(IPT_CONNTRACK-m) $(IPT_NAT-m))))"
 
+ifneq ($(wildcard $(PKG_BUILD_DIR)/.config_*),$(subst .configured_,.config_,$(STAMP_CONFIGURED)))
+  define Build/Configure/rebuild
+       $(FIND) $(PKG_BUILD_DIR) -name \*.o -or -name \*.\?o -or -name \*.a | $(XARGS) rm -f
+       rm -f $(PKG_BUILD_DIR)/.config_*
+       rm -f $(PKG_BUILD_DIR)/.configured_*
+       touch $(subst .configured_,.config_,$(STAMP_CONFIGURED))
+  endef
+endif
+
+define Build/Configure
+$(Build/Configure/rebuild)
+$(Build/Configure/Default)
+endef
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(INSTALL_DIR) $(1)/usr/include/iptables