allow mkfwimage to fail during atheros builds.
authorFelix Fietkau <nbd@openwrt.org>
Sat, 26 Jul 2008 13:32:02 +0000 (13:32 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 26 Jul 2008 13:32:02 +0000 (13:32 +0000)
sometimes images get too big for devices that use this image format,
but this must not break the normal image build for other atheros devices

SVN-Revision: 11934

target/linux/atheros/image/Makefile

index 17b18deeed33fd0c5d47017b1a910414b675dd2c..343e2dedf70e6346fc9ff4f536b2f5f0cf1d4ec3 100644 (file)
@@ -23,11 +23,11 @@ define Image/Build
        $(call Image/Build/$(1))
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
 
-       $(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+       -$(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
                -v XS2.ar2316.OpenWRT \
                -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
-       $(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+       -$(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
                -v XS5.ar2313.OpenWRT \
                -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin \