xtables-addons: Update to 1.29. This fixes compile on linux-2.6.36. Also fix parallel...
authorMichael Büsch <mb@bu3sch.de>
Sat, 2 Oct 2010 19:30:17 +0000 (19:30 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sat, 2 Oct 2010 19:30:17 +0000 (19:30 +0000)
SVN-Revision: 23185

net/xtables-addons/Makefile
net/xtables-addons/patches/001-no_depmod.patch

index e1f7911..f63e6d2 100644 (file)
@@ -9,13 +9,15 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
-PKG_VERSION:=1.28
+PKG_VERSION:=1.29
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=2d81508449ddd7295e9dc08aff72d377
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=25e3d7de905d8ed7cfb5e297a316bfc8
 PKG_SOURCE_URL:=@SF/xtables-addons
 PKG_BUILD_DEPENDS:=iptables
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -34,13 +36,23 @@ CONFIGURE_ARGS+= \
        --with-xtlibdir="/usr/lib/iptables" \
 
 define Build/Compile
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               DEPMOD="/bin/true" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               all
+endef
+
+define Build/Install
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARCH="$(LINUX_KARCH)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                DEPMOD="/bin/true" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               all install
+               install
 endef
 
 # 1: extension/module suffix used in package name
index 50820c7..611af34 100644 (file)
@@ -1,6 +1,10 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -752,8 +752,7 @@ install-dvi: install-dvi-recursive
+---
+ Makefile.in |    3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+--- xtables-addons-1.29.orig/Makefile.in
++++ xtables-addons-1.29/Makefile.in
+@@ -754,8 +754,7 @@ install-dvi: install-dvi-recursive
  install-dvi-am:
  
  install-exec-am: