[include] autotools.mk: don't rely on shipped autogen.sh files
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 15 Dec 2010 01:14:14 +0000 (01:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 15 Dec 2010 01:14:14 +0000 (01:14 +0000)
SVN-Revision: 24573

include/autotools.mk

index 308b45a5f3a2e572956c2ed8f7b204b62024df28..4d98a7cd0a682ccf14a3e9f87c8448e34a129e5c 100644 (file)
@@ -32,9 +32,7 @@ define autoreconf
        (cd $(1); \
                $(patsubst %,rm -f %;,$(2)) \
                $(foreach p,$(3), \
-                       if [ -x $(p)/autogen.sh ]; then \
-                               $(AM_TOOL_PATHS) $(p)/autogen.sh || true; \
-                       elif [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
+                       if [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
                                [ -f $(p)/aclocal.m4 ] && [ ! -f $(p)/acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
                                [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
                                $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \