Put each xserver(xorg,kdrive-xvesa,kdrive-xfbdev) into its own package, which
authorLars-Peter Clausen <lars@metafoo.de>
Thu, 20 Nov 2008 00:20:30 +0000 (00:20 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Thu, 20 Nov 2008 00:20:30 +0000 (00:20 +0000)
all provide the virtual xserver package.
Cleanup some xorg driver makefiles.

SVN-Revision: 13294

26 files changed:
Xorg/app/font-util/Makefile
Xorg/driver/xf86-input-evdev/Makefile
Xorg/driver/xf86-input-keyboard/Makefile
Xorg/driver/xf86-input-mouse/Makefile
Xorg/driver/xf86-video-ati/Makefile
Xorg/driver/xf86-video-fbdev/Makefile
Xorg/driver/xf86-video-intel/Makefile
Xorg/driver/xf86-video-nv/Makefile
Xorg/driver/xf86-video-vesa/Makefile
Xorg/font/encodings/Makefile
Xorg/font/font-alias/Makefile
Xorg/font/font-bh-75dpi/Makefile
Xorg/font/font-cursor-misc/Makefile
Xorg/font/font-daewoo-misc/Makefile
Xorg/font/font-dec-misc/Makefile
Xorg/font/font-ibm-type1/Makefile
Xorg/font/font-isas-misc/Makefile
Xorg/font/font-jis-misc/Makefile
Xorg/font/font-micro-misc/Makefile
Xorg/font/font-misc-cyrillic/Makefile
Xorg/font/font-misc-misc/Makefile
Xorg/font/font-xfree86-type1/Makefile
Xorg/xserver/xorg-xserver/Config.in
Xorg/xserver/xorg-xserver/Makefile
Xorg/xserver/xorg-xserver/files/config/generic [new file with mode: 0644]
Xorg/xserver/xorg-xserver/files/config/olpc

index 181e705ddc65b7f05ba69682c4110e5e78ecb9cf..9e53bf2684f2f3e60618d7929a113655536d536e 100644 (file)
@@ -22,7 +22,7 @@ define Package/font-util
   CATEGORY:=Xorg
   SUBMENU:=app
   TITLE:=misc tool to generate x fonts
-  DEPENDS:=+xorg-server @DISPLAY_SUPPORT
+  DEPENDS:=+xserver @DISPLAY_SUPPORT
 endef
 
 define Build/Configure
index 1c7eecbef184a6c877b8da871bc340e3ce29c6d7..d27e6ea7d651534c9bbfed051d68305a20c3d6a4 100644 (file)
@@ -21,7 +21,7 @@ define Package/xf86-input-evdev
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xorg-server  @DISPLAY_SUPPORT
+  DEPENDS:=+xserver-xorg
   TITLE:=xf86-input-evdev
   URL:=http://xorg.freedesktop.org/
 endef
index 9b2860ae8885e5b93d7daf205ba64840c4cc5099..38c1b0a2040604caf45e8759eac6b130a95d07fc 100644 (file)
@@ -21,7 +21,7 @@ define Package/xf86-input-keyboard
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xorg-server  @DISPLAY_SUPPORT
+  DEPENDS:=+xserver-xorg  @DISPLAY_SUPPORT
   TITLE:=xf86-input-keyboard
   URL:=http://xorg.freedesktop.org/
 endef
index 17e9a8eb47f707ff2a18546965696b1eb3ae44e1..1fa0a456cf46b5fddff7c8a6f671cd47c1a9bd22 100644 (file)
@@ -21,7 +21,7 @@ define Package/xf86-input-mouse
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xorg-server  @DISPLAY_SUPPORT
+  DEPENDS:=+xserver-xorg @DISPLAY_SUPPORT
   TITLE:=xf86-input-mouse
   URL:=http://xorg.freedesktop.org/
 endef
index b96cd3614b6160f035a8a53b9f81bc48465f6862..17ff63fd0b28b3c5eeda7241618936f865e9e2f9 100644 (file)
@@ -21,7 +21,7 @@ define Package/xf86-video-ati
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xorg-server @BROKEN @DISPLAY_SUPPORT
+  DEPENDS:=+xserver-xorg @BROKEN
   TITLE:=xf86-video-ati
   URL:=http://xorg.freedesktop.org/
 endef
index 90c4a4e68dbd290488edc9c95064b9cfbb41aace..a26bb8869543b5cbbac6aef7afd243a5d922129c 100644 (file)
@@ -17,55 +17,28 @@ PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_INSTALL:=1
+
 define Package/xf86-video-fbdev
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xorg-server  @DISPLAY_SUPPORT
+  DEPENDS:=+xserver-xorg +libpciaccess
   TITLE:=xf86-video-fbdev
   URL:=http://xorg.freedesktop.org/
 endef
 
-define Build/InstallDev
-       DESTDIR="$(1)" $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
-endef
-
-EXTRA_CPPFLAGS= -I$(STAGING_DIR)/usr/include/xorg \
-               -I$(STAGING_DIR)/usr/include/X11/ \
-               -I$(STAGING_DIR)/usr/include/ \
-               -I$(STAGING_DIR)/include/
-
-EXTRA_CFLAGS+= $(EXTRA_CPPFLAGS)
-
-acvar=$(subst -,_,$(subst .,_,$(subst /,_,$(1))))
-
-CONFIGURE_VARS +=DRI_CFLAGS="-I$(STAGING_DIR)/usr/include/X11/dri/" ac_cv_file__usr_share_sgml_X11_defs_ent=yes \
-       sdkdir=$(STAGING_DIR) 
-
 define Build/Configure
-       (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
-       if [ -x $(CONFIGURE_CMD) ]; then \
-               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
-               $(foreach a,dri.h sarea.h dristruct.h exa.h damage.h,export ac_cv_file_$(call acvar,$(STAGING_DIR)/usr/include/xorg/$(a))=yes;) \
-               sed -i "s|sdkdir=.*|sdkdir=$(STAGING_DIR)/usr/include/xorg|g" $(PKG_BUILD_DIR)/configure ;\
-               $(CONFIGURE_VARS) \
-               $(CONFIGURE_CMD) \
-               $(CONFIGURE_ARGS_XTRA) \
-               $(CONFIGURE_ARGS) \
-               CPPFLAGS="$(EXTRA_CPPFLAGS)" ;\
-       fi \
+       $(call Build/Configure/Default, \
+               --enable-pciaccess \
        )
 endef
 
-define Build/Compile
-       make -C $(PKG_BUILD_DIR)
-       DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) install
-       find $(PKG_INSTALL_DIR) -name *a | xargs rm -rf
-endef
-
 define Package/xf86-video-fbdev/install
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/xorg/modules/drivers
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/xorg/modules/drivers/*.so \
+               $(1)/usr/lib/xorg/modules/drivers
 endef
 
 $(eval $(call BuildPackage,xf86-video-fbdev))
index 57b78576b68dc204375682fc1bdbdd3b6dd98e3d..e1763d2a933414b73c0cce14784da14583afe38b 100644 (file)
@@ -21,7 +21,7 @@ define Package/xf86-video-intel
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xorg-server  @DISPLAY_SUPPORT
+  DEPENDS:=+xserver-xorg
   TITLE:=xf86-video-intel
   URL:=http://xorg.freedesktop.org/
 endef
index 10ce6277ac9c103bef9edcd568035c0cf6a71194..a5e8036af0b4e3618baedf1ad7d42099a322a16c 100644 (file)
@@ -21,7 +21,7 @@ define Package/xf86-video-nv
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xorg-server  @DISPLAY_SUPPORT
+  DEPENDS:=+xserver-xorg
   TITLE:=xf86-video-nv
   URL:=http://xorg.freedesktop.org/
 endef
index a509027372f0e837931691aa44e8ce3d099e06cb..75c8bb78e2449992eaf4078aef283a588f6011bd 100644 (file)
@@ -21,7 +21,7 @@ define Package/xf86-video-vesa
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xorg-server  @DISPLAY_SUPPORT
+  DEPENDS:=+xserver-xorg
   TITLE:=xf86-video-vesa
   URL:=http://xorg.freedesktop.org/
 endef
index 00af6a402aed41ee6cb0c24dcd6e34be0fb59401..132c79246e50cd0bcb823a991875b79417a2fd07 100644 (file)
@@ -21,7 +21,7 @@ define Package/encodings
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=encodings
   URL:=http://xorg.freedesktop.org/
 endef
index 7644640527605cf483c35a8d1e82d33c69abe63a..26357acd264ea8e960d9268c490a3a9b65728960 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-alias
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-alias
   URL:=http://xorg.freedesktop.org/
 endef
index 26d3980565919b1109798f73495a4503a6e778dd..d71ba89211792b20f4e180971f2ea7b79a72d35d 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-bh-75dpi
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-bh-75dpi
   URL:=http://xorg.freedesktop.org/
 endef
index 7dcf9bb6ab3cd6e389e8a8cc37f4a081fc9b080d..723023039ba3890313216cb0d845f5df17edc1bc 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-cursor-misc
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-cursor-misc
   URL:=http://xorg.freedesktop.org/
 endef
index 55e7549e2f1d408010f4f2a9ed23ff6856a36db7..5a36ae22d376a8828348863c472f53a39480ced7 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-daewoo-misc
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-daewoo-misc
   URL:=http://xorg.freedesktop.org/
 endef
index 030813f294f163754016238ae4bfb390264459db..79bd64fbfc185eba791abd6aef636a82c7d4f045 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-dec-misc
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-dec-misc
   URL:=http://xorg.freedesktop.org/
 endef
index 052b3ce4ddf1ae8e63d5498fcfa178bc1c04806c..e84cfbb3254ff53d611fa6dc06915e323997aa37 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-ibm-type1
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-ibm-type1
   URL:=http://xorg.freedesktop.org/
 endef
index b0ff8cb6a05f122796c6d985d3ed7dadcf5f90b3..b21eb8adea773fda6f10627aeedaf5d3104ee013 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-isas-misc
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-isas-misc
   URL:=http://xorg.freedesktop.org/
 endef
index ffe2bc1c04f0acaebf67f7ec1126041bd2968a3e..bc9126f821d1bf1914293aeea5fcdd3211f7dd2e 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-jis-misc
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-jis-misc
   URL:=http://xorg.freedesktop.org/
 endef
index 6415fa63f61ecaf15f55eb8772f72c8f303d4fb5..f25da3fbacaaa81b97ecf01e8f9a38e126fc0cf1 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-micro-misc
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-micro-misc
   URL:=http://xorg.freedesktop.org/
 endef
index 9c2b4ee7888b8ccffbb244b7ec583c76003fe534..a0f64f3a53c7e1b1050e565b3f4766ec16429e19 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-misc-cyrillic
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-misc-cyrillic
   URL:=http://xorg.freedesktop.org/
 endef
index a481ef43004a283db55d0e936f70766ccd1ed547..cb541c723dca75126b1b5af09e3b2e6a900af4c7 100644 (file)
@@ -25,7 +25,7 @@ endef
 
 define Package/font-base
   $(call Package/font-misc-misc/Default)
-  DEPENDS:=+xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:=+xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-base 
   URL:=http://xorg.freedesktop.org/
 endef
index 11e599d10d414d2fe81c31ed0e1af2f1cd7108c1..a0a1625c93ad6f36865d157bc556f9bf97fee2ed 100644 (file)
@@ -21,7 +21,7 @@ define Package/font-xfree86-type1
   SECTION:=xorg-font
   CATEGORY:=Xorg
   SUBMENU:=font
-  DEPENDS:= +xorg-server +font-util @DISPLAY_SUPPORT
+  DEPENDS:= +xserver +font-util @DISPLAY_SUPPORT
   TITLE:=font-xfree86-type1
   URL:=http://xorg.freedesktop.org/
 endef
index 986904d1e204405e2c6c4bdedf73ffe46794fa91..32e2d8dc99ee1048da2fcb381acf97c8f0eb452e 100644 (file)
@@ -1,31 +1,34 @@
-#comment "type of xserver ---"
-
-#config X_KDRIVE
-#      bool
-#      prompt "use kdrive instead of xorg"
-
-comment "library support for xserver ---"
-
-config X_TSLIB
-       bool
-       prompt "enable support for tslib"
-
-#config X_XCALIBRATE
-#      bool
-#      prompt "enable support for xcalibrate"
-
-#config X_DRI
-#      bool
-#      prompt "enable support for DRI"
-
-config X_COMPOSITE
-       bool
-       prompt "enable support for composite"
-
-config X_XINERAMA
-       bool
-       prompt "enable support for xinerama"
-
-#config X_GLX
-#      bool
-#      prompt "enable support for GLX"
+menu "kdrive library support --->"
+depends on PACKAGE_xserver-kdrive-xvesa || PACKAGE_xserver-kdrive-xfbdev
+
+       config X_TSLIB
+               bool
+               prompt "enable support for tslib"
+               depends PACKAGE_xserver-kdrive-xvesa || PACKAGE_xserver-kdrive-xfbdev
+
+#      config X_XCALIBRATE
+#              bool
+#              prompt "enable support for xcalibrate"
+#              depends PACKAGE_xserver-kdrive-xvesa || PACKAGE_xserver-kdrive-xfbdev
+
+#      config X_DRI
+#              bool
+#              prompt "enable support for DRI"
+#              depends PACKAGE_xserver-kdrive-xvesa || PACKAGE_xserver-kdrive-xfbdev
+
+       config X_COMPOSITE
+               bool
+               prompt "enable support for composite"
+               depends PACKAGE_xserver-kdrive-xvesa || PACKAGE_xserver-kdrive-xfbdev
+
+       config X_XINERAMA
+               bool
+               prompt "enable support for xinerama"
+               depends PACKAGE_xserver-kdrive-xvesa || PACKAGE_xserver-kdrive-xfbdev
+
+#      config X_GLX
+#              bool
+#              prompt "enable support for GLX"
+#              depends PACKAGE_xserver-kdrive-xvesa || PACKAGE_xserver-kdrive-xfbdev
+
+endmenu
index 99772351266188d685973a2abf881dabeb82cd01..6e2e9c176d2ce11c547e34ed3dc81e37c257aa7a 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -17,29 +17,43 @@ PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/xserver/xorg-server-$(PKG_VERSION)/
 
 include $(INCLUDE_DIR)/package.mk
 
-EXTRA_CFLAGS+= -I${STAGING_DIR}/usr/include/X11/GL -I${STAGING_DIR}/usr/include/X11/dri/ -I${STAGING_DIR}/usr/include/X11/ -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
-
-CONFIGURE_ARGS+= --disable-dga \
-               --disable-xf86misc \
-               --disable-xf86vidmode \
-               --disable-xf86bigfont \
-               --disable-xorgcfg \
-               --disable-xkb \
-               --disable-xnest \
-               --disable-xvfb \
-               --disable-xevie \
-               --disable-xprint \
-               --disable-xtrap \
-               --disable-dmx \
-               --disable-w100 \
-               --disable-glx \
-               --enable-xfbdev \
-               --enable-kdrive \
-               --disable-xorg \
-               --disable-xephyr \
-               --enable-builtin-fonts \
-               --disable-kdrive-vesa \
-               --with-default-font-path=built-ins \
+EXTRA_CFLAGS+= \
+       -I$(STAGING_DIR)/usr/include/X11/GL \
+       -I$(STAGING_DIR)/usr/include/X11/dri/ \
+       -I$(STAGING_DIR)/usr/include/X11/ \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+CONFIGURE_ARGS+= \
+       --disable-aiglx \
+       --disable-glx-tls \
+       --disable-dga \
+       --disable-xdmcp \
+       --disable-xdm-auth-1 \
+       --disable-dri \
+       --disable-config-hal \
+       --disable-xf86misc \
+       --disable-xf86vidmode \
+       --disable-xf86bigfont \
+       --disable-xorgcfg \
+       --disable-xkb \
+       --disable-xnest \
+       --disable-xquartz \
+       --disable-xwin \
+       --disable-x11app \
+       --disable-xsdl \
+       --disable-xfake \
+       --disable-install-setuid \
+       --disable-kbd_mode \
+       --disable-xvfb \
+       --disable-xevie \
+       --disable-xprint \
+       --disable-xtrap \
+       --disable-dmx \
+       --disable-glx \
+       --enable-xorg \
+       --disable-xephyr \
+       --enable-builtin-fonts \
+       --with-default-font-path=built-ins \
 
 CONFIGURE_VARS+=ac_cv_file__usr_share_sgml_X11_defs_ent=yes
 
@@ -90,47 +104,31 @@ CONFIGURE_VARS+=ac_cv_file__usr_share_sgml_X11_defs_ent=yes
 #              +pixman \
 #              @DISPLAY_SUPPORT
 
-define Package/xorg-server/config
-       menu "Configuration"
-       depends on PACKAGE_xorg-server
+define Package/xserver-common/config
        source "$(SOURCE)/Config.in"
-       endmenu
 endef
 
-X_BIN_FILE=Xfbdev # no Xorg-binary when xorg is disabled :)
-#ifneq ($(CONFIG_X_KDRIVE),)
-# CONFIGURE_ARGS+=--enable-kdrive --disable-xorg
-#  X_BIN_FILE=Xfbdev # no Xorg-binary when xorg is disabled :)
-#else
-#  CONFIGURE_ARGS+=--disable-kdrive --enable-xorg
-#  X_BIN_FILE=Xorg
-#endif
-
+# TODO: Move config file to indepedndent packages
 ifeq ($(CONFIG_TARGET_olpc),y)
-  #XORG_CONFIG_FILE=xorg-olpc.conf
   X_CONFIG=olpc
-endif
+else
 ifeq ($(CONFIG_TARGET_om_gta02),y)
-  #XORG_CONFIG_FILE=xorg-om_gta02.conf
   X_CONFIG=om_gta02
+else
+  X_CONFIG=generic
+endif
 endif
 
-define Package/xorg-server/Default
+define Package/xorg/Default
   SECTION:=xorg-server
   CATEGORY:=Xorg
+  SUBMENU:=server
   URL:=http://xorg.freedesktop.org/
 endef
 
-define Package/xorg-server
-$(call Package/xorg-server/Default) 
-  TITLE:=Xorg server
-  MENU:=1
-  DEPENDS:=+X_TSLIB:tslib \
-  +X_DRI:xf86driproto \
-  +X_DRI:libdrm \
-  +X_XCALIBRATE:calibrateproto \
-  +X_COMPOSITE:compositeproto \
-  +X_XINERAMA:xineramaproto \
+define Package/xserver/Default
+$(call Package/xorg/Default)
+  DEPENDS:=+xserver-common \
   +libpthread \
   +randrproto \
   +renderproto \
@@ -157,69 +155,150 @@ $(call Package/xorg-server/Default)
   @DISPLAY_SUPPORT
 endef
 
-define Package/xorg-server-config
-$(call Package/xorg-server/Default) 
-  TITLE:=Xorg server configuration tools 
-  DEPENDS:=xorg-server
+define Package/xserver-xorg
+$(call Package/xserver/Default)
+  PROVIDES:=xserver
+  TITLE:=Xorg xserver
+endef
+
+define Package/xserver-kdrive-xvesa
+$(call Package/xserver/Default)
+  PROVIDES:=xserver
+  TITLE:=Kdrive vesa xserver
+  DEPENDS+=+X_TSLIB:tslib \
+  +X_DRI:xf86driproto \
+  +X_DRI:libdrm \
+  +X_XCALIBRATE:calibrateproto \
+  +X_COMPOSITE:compositeproto \
+  +X_XINERAMA:xineramaproto
+endef
+
+define Package/xserver-kdrive-xfbdev
+$(call Package/xserver/Default)
+  PROVIDES:=xserver
+  TITLE:=Kdrive framebuffer xserver
+  DEPENDS+=+X_TSLIB:tslib \
+  +X_DRI:xf86driproto \
+  +X_DRI:libdrm \
+  +X_XCALIBRATE:calibrateproto \
+  +X_COMPOSITE:compositeproto \
+  +X_XINERAMA:xineramaproto
+endef
+
+define Package/xserver-xorg-config
+$(call Package/xorg/Default)
+  TITLE:=Xorg server configuration tools
+  DEPENDS:=xserver-xorg
+endef
+
+define Package/xserver-common
+$(call Package/xorg/Default)
+  TITLE:=Files shared by the different webservers
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR) \
-               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
-               $(CONFIGURE_VARS) \
-               $(CONFIGURE_CMD) \
-               $(CONFIGURE_ARGS_XTRA) \
-               $(CONFIGURE_ARGS) \
-               $(if $(CONFIG_X_TSLIB),--enable-tslib) \
-               $(if $(CONFIG_X_COMPOSITE),,--disable-composite) \
-               $(if $(CONFIG_X_XINERAMA),,--disable-xinerama) \
-               $(if $(CONFIG_X_DRI),,--disable-dri) \
-               $(if $(CONFIG_X_XCALIBRATE),--enable-xcalibrate) \
-               );
+       $(call Build/Configure/Default, \
+               $(if $(CONFIG_PACKAGE_xserver-xorg),--enable-xorg,--disable-xorg) \
+               $(if $(CONFIG_PACKAGE_xserver-xvesa), \
+                       --enable-kdrive-vesa, \
+                       --disable-kdrive-vesa) \
+               $(if $(CONFIG_PACKAGE_xserver-xfbdev), \
+                       --enable-xfbdev, \
+                       --disable-xfbdev) \
+               $(if $(CONFIG_PACKAGE_xserver-xfbdev)$(CONFIG_PACKAGE_xserver-xvesa), \
+                       --enable-kdrive, \
+                       --disable-kdrive) \
+               $(if $(CONFIG_X_TSLIB),--enable-tslib,--disable-tslib) \
+               $(if $(CONFIG_X_COMPOSITE),--enable-composite,--disable-composite) \
+               $(if $(CONFIG_X_XINERAMA),--enable-xinerama,--disable-xinerama) \
+               $(if $(CONFIG_X_DRI),--enable-dri,--disable-dri) \
+               $(if $(CONFIG_X_XCALIBRATE),--enable-xcalibrate,--disable-xcalibrate) \
+       )
 endef
 
 define Build/Compile
        DESTDIR="$(PKG_INSTALL_DIR)" $(MAKE) -C $(PKG_BUILD_DIR) install
 endef
 
-define Package/xorg-server/install
-       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib $(1)/etc/init.d $(1)/etc/config
-       #$(CP) $(PKG_INSTALL_DIR)/usr/bin/$(X_BIN_FILE) $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
-       $(CP) ./files/x.init $(1)/etc/init.d/x11
-       $(if $(X_CONFIG),$(CP) ./files/config/$(X_CONFIG) $(1)/etc/config/x11)
-       cd $(1)/usr/bin; ln -sf $(X_BIN_FILE) X
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
-endef
-
-#define Package/xorg-server/install
-#      $(INSTALL_DIR) $(1)/usr/bin
-#      $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(XORG_BIN_FILE) $(1)/usr/bin/
-#      cd $(1)/usr/bin; ln -sf $(XORG_BIN_FILE) X
-#      $(INSTALL_DIR) $(1)/usr/share
-#      $(CP) $(PKG_INSTALL_DIR)/usr/share/* $(1)/usr/share/
-#      $(INSTALL_DIR) $(1)/usr/lib/xserver
-#      $(CP) $(PKG_INSTALL_DIR)/usr/lib/xserver/* $(1)/usr/lib/xserver
-#      $(INSTALL_DIR) $(1)/usr/lib/xorg/
-#      $(CP) -r $(PKG_INSTALL_DIR)/usr/lib/xorg/* $(1)/usr/lib/xorg/
-#      find $(1)/usr/lib/xorg/ -name *.la | xargs rm -rf
-#      $(INSTALL_DIR) $(1)/usr/lib/X11/
-#      $(CP) -r $(PKG_INSTALL_DIR)/usr/lib/X11/* $(1)/usr/lib/X11/
-#      rm -rf $(1)/usr/share/X11 $(1)/usr/lib/X11/xserver      
-#      $(INSTALL_DIR) $(1)/var/log/
-#      $(INSTALL_DIR) $(1)/etc/X11/
-#      $(CP) files/$(XORG_CONFIG_FILE) $(1)/etc/X11/xorg.conf
-#endef
+define Package/xserver-common/install
+       $(INSTALL_DIR) $(1)/etc/{init.d,config}
+       $(INSTALL_DATA) \
+               ./files/x.init \
+               $(1)/etc/init.d/x11
+       $(if $(X_CONFIG), \
+               $(INSTALL_DATA) \
+                       ./files/config/$(X_CONFIG) \
+                       $(1)/etc/config/x11 \
+       )
+
+       $(INSTALL_DIR) $(1)/usr/lib/xorg
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/xorg/protocol.txt \
+               $(1)/usr/lib/xorg/
+endef
+
+define Package/xserver-xfdev/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(1)/usr/bin/Xfbdev \
+               $(PKG_INSTALL_DIR)/usr/bin/Xfbdev
+endef
+
+define Package/xserver-xvesa/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(1)/usr/bin/Xvesa \
+               $(PKG_INSTALL_DIR)/usr/bin/Xvesa
+endef
+
+define Package/xserver-xorg/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/Xorg \
+               $(1)/usr/bin/
+
+       $(INSTALL_DIR) $(1)/usr/lib/X11
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/X11/* \
+               $(1)/usr/lib/X11/
+
+       $(INSTALL_DIR) $(1)/usr/lib/xorg/modules/{extensions,fonts,linux,multimedia}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/xorg/modules/*.so \
+               $(1)/usr/lib/xorg/modules/
+
+       $(for dir,extensions fonts linux multimedia, \
+               $(INSTALL_DATA) \
+                       $(PKG_INSTALL_DIR)/usr/lib/xorg/modules/$(d)/*.so \
+                       $(1)/usr/lib/xorg/modules/$(d) \
+       )
+endef
 
 define Packages/xorg-server-config/install
        $(INSTALL_DIR) $(1)/usr/bin
-   $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xorgconfig $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xorgconfig $(1)/usr/bin/
 endef
 
 define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/share/aclocal/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/aclocal/* \
+               $(1)/usr/share/aclocal/
+
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+       $(if $(CONFIG_PACKAGE_xserver-xorg), \
+               $(INSTALL_DIR) $(1)/usr/include/xorg; \
+               $(INSTALL_DATA) \
+                       $(PKG_INSTALL_DIR)/usr/include/xorg/*.h \
+                       $(1)/usr/include/xorg/; \
+       )
 endef
 
-$(eval $(call BuildPackage,xorg-server))
-$(eval $(call BuildPackage,xorg-server-config))
+$(eval $(call BuildPackage,xserver-common))
+$(eval $(call BuildPackage,xserver-xorg))
+$(eval $(call BuildPackage,xserver-kdrive-xvesa))
+$(eval $(call BuildPackage,xserver-kdrive-xfbdev))
+$(eval $(call BuildPackage,xserver-xorg-config))
diff --git a/Xorg/xserver/xorg-xserver/files/config/generic b/Xorg/xserver/xorg-xserver/files/config/generic
new file mode 100644 (file)
index 0000000..7f2e177
--- /dev/null
@@ -0,0 +1,15 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config screen
+       option  resolution      800x600
+       option  dpi     285
+
+config graphic
+       option  device  /dev/fb0
+
+config input mouse
+       option  device  /dev/psaux
+       option  driver  mouse
+
+config input keybd
+       option  driver  keyboard
index e69de29bb2d1d6434b8b29ae775ad8c2e48c5391..825e1fa1b9978033c3be594bcf93096e37aa3257 100644 (file)
@@ -0,0 +1,12 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config screen
+       option  resolution      1200x900
+       option  dpi     285
+
+config graphic
+       option  device  /dev/fb0
+
+config input mouse
+       option  device  /dev/event1
+       option  driver  tslib