[sdk] make sure .config gets copied as file
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 28 Jan 2012 03:30:30 +0000 (03:30 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 28 Jan 2012 03:30:30 +0000 (03:30 +0000)
When using scripts/env, .config is most likely a symbolic link
pointing to env/.config. Previously the symbolic link got
copied as-is into the SDK tarball, leading to a dangling .config
symlink on the target system which prevented the SDK from working.

SVN-Revision: 29927

target/sdk/Makefile

index bad50993d6572145384e3cf2c7cb080a50bc82f9..737404108dcfb1e8a0f7fe5a6f572b8314a7f58a 100644 (file)
@@ -40,7 +40,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
        rm -rf \
                $(SDK_BUILD_DIR)/target/linux/*/files \
                $(SDK_BUILD_DIR)/target/linux/*/patches
-       $(CP) \
+       $(CP) -L \
                $(TOPDIR)/LICENSE \
                $(TOPDIR)/rules.mk \
                $(TOPDIR)/.config \