don't use locales when retrieving subversion release number (closes: #54)
authorNicolas Thill <nico@openwrt.org>
Sun, 27 Nov 2005 19:59:03 +0000 (19:59 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 27 Nov 2005 19:59:03 +0000 (19:59 +0000)
SVN-Revision: 2557

openwrt/package/base-files/Makefile

index 48099c9470a680d6e21009bc7663d6869a52fe30..16169fa28d9aea42b80924c9b84d34ae95ed4cb6 100644 (file)
@@ -6,7 +6,7 @@ PKG_NAME:=base-files
 PKG_RELEASE:=6
 PKG_BUILD_DIR:=$(BUILD_DIR)/base-files
 
-REV:=${shell svn info | grep Revision | cut -d ' ' -f 2}
+REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
 ifeq ($(REV),)
 REV:=0
 endif