Using find's -exec to remove directories causes 'not found' errors when find tries...
authorMike Baker <mbm@openwrt.org>
Tue, 3 Apr 2007 11:56:08 +0000 (11:56 +0000)
committerMike Baker <mbm@openwrt.org>
Tue, 3 Apr 2007 11:56:08 +0000 (11:56 +0000)
SVN-Revision: 6849

Makefile
include/package-ipkg.mk
scripts/feeds.sh

index ab4c4d57b65c6ff3dc6fff905a6780468272bb7a..05c4f450e1f04bcc34b96073ee006daa1e04a498 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -171,7 +171,7 @@ docclean:
        $(MAKE) -C docs/ clean
 
 symlinkclean:
        $(MAKE) -C docs/ clean
 
 symlinkclean:
-       find package -type l -exec rm -f {} \;
+       find package -type l -exec rm -f {} +
 
 .SILENT: clean dirclean distclean symlinkclean config-clean download world
 FORCE: ;
 
 .SILENT: clean dirclean distclean symlinkclean config-clean download world
 FORCE: ;
index d824d268f4127ca153f2ee2d175dc203d4ce58de..8b317065bfd4bf04ab20ac051f4c6e2fb53e72a3 100644 (file)
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   -exec rm -rf {} \;
-       -find $$(IDIR_$(1)) -name .svn  -exec rm -rf {} \;
-       -find $$(IDIR_$(1)) -name '.#*' -exec rm -f  {} \;
+       -find $$(IDIR_$(1)) -name CVS   -exec rm -rf {} +
+       -find $$(IDIR_$(1)) -name .svn  -exec rm -rf {} +
+       -find $$(IDIR_$(1)) -name '.#*' -exec rm -f  {} +
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false 
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false 
index d2dfe9da9f26e3c1d0f615d59f956418b0239b82..9fc3343a1be14a51a8e5587e920110f46afc923b 100755 (executable)
@@ -22,7 +22,7 @@ cd $TOPDIR
 
 # Some functions we might call several times a run
 delete_symlinks() {
 
 # Some functions we might call several times a run
 delete_symlinks() {
-       find $1 -type l -exec rm -f {} \;
+       find $1 -type l -exec rm -f {} +
 }
 
 setup_symlinks() {
 }
 
 setup_symlinks() {