kernel: update linux 3.2 to 3.2.5
authorGabor Juhos <juhosg@openwrt.org>
Fri, 10 Feb 2012 08:19:23 +0000 (08:19 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 10 Feb 2012 08:19:23 +0000 (08:19 +0000)
SVN-Revision: 30401

include/kernel-version.mk
target/linux/au1000/Makefile
target/linux/ep93xx/Makefile
target/linux/generic/patches-3.2/020-ssb_update.patch
target/linux/omap4/Makefile

index a37edf29d55ac3b8bea6d5d334d0effe30d8b7d4..66aca0dfeb28b496c8d7a36bf9626da889dcc12c 100644 (file)
@@ -35,8 +35,8 @@ endif
 ifeq ($(LINUX_VERSION),3.1.10)
   LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
 endif
 ifeq ($(LINUX_VERSION),3.1.10)
   LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
 endif
-ifeq ($(LINUX_VERSION),3.2.2)
-  LINUX_KERNEL_MD5SUM:=c0303125c8eda431b10084eece7564e3
+ifeq ($(LINUX_VERSION),3.2.5)
+  LINUX_KERNEL_MD5SUM:=17c180eaa524101ca1c675bd675eca37
 endif
 
 # disable the md5sum check for unknown kernel versions
 endif
 
 # disable the md5sum check for unknown kernel versions
index f619df5bb2b5a8e0d5ab2258636bdf3beb94aac9..1ce821bb1a7b79d8b4afaea33db39ec73f1e90f2 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.2
+LINUX_VERSION:=3.2.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index 84e467112144ddb025af239635312be665d00684..5a6121db5a560ecf383fe50e2ba03ce1495525b8 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.2
+LINUX_VERSION:=3.2.5
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index ca686f361c0ab897d7f166f5db9240b5a64b26ed..1fe1768f1a4332f82bdbf2b85cd186a1f3cf3ca1 100644 (file)
  #define SSB_SPROM8_CCK2GPO            0x0140  /* CCK power offset */
  #define SSB_SPROM8_OFDM2GPO           0x0142  /* 2.4GHz OFDM power offset */
  #define SSB_SPROM8_OFDM5GPO           0x0146  /* 5.3GHz OFDM power offset */
  #define SSB_SPROM8_CCK2GPO            0x0140  /* CCK power offset */
  #define SSB_SPROM8_OFDM2GPO           0x0142  /* 2.4GHz OFDM power offset */
  #define SSB_SPROM8_OFDM5GPO           0x0146  /* 5.3GHz OFDM power offset */
-@@ -502,6 +553,46 @@
- #define SSB_BFL2_SPUR_WAR             0x0200  /* has a workaround for clock-harmonic spurs */
- #define SSB_BFL2_GPLL_WAR             0x0400  /* altenative G-band PLL settings implemented */
+@@ -464,6 +515,46 @@
  
  
-+/* Values for boardflags_lo read from SPROM */
-+#define SSB_BFL_BTCOEXIST             0x0001  /* implements Bluetooth coexistance */
+ /* Values for boardflags_lo read from SPROM */
+ #define SSB_BFL_BTCOEXIST             0x0001  /* implements Bluetooth coexistance */
 +#define SSB_BFL_PACTRL                        0x0002  /* GPIO 9 controlling the PA */
 +#define SSB_BFL_AIRLINEMODE           0x0004  /* implements GPIO 13 radio disable indication */
 +#define SSB_BFL_RSSI                  0x0008  /* software calculates nrssi slope. */
 +#define SSB_BFL_PACTRL                        0x0002  /* GPIO 9 controlling the PA */
 +#define SSB_BFL_AIRLINEMODE           0x0004  /* implements GPIO 13 radio disable indication */
 +#define SSB_BFL_RSSI                  0x0008  /* software calculates nrssi slope. */
 +#define SSB_BFL2_SPUR_WAR             0x0200  /* has a workaround for clock-harmonic spurs */
 +#define SSB_BFL2_GPLL_WAR             0x0400  /* altenative G-band PLL settings implemented */
 +
 +#define SSB_BFL2_SPUR_WAR             0x0200  /* has a workaround for clock-harmonic spurs */
 +#define SSB_BFL2_GPLL_WAR             0x0400  /* altenative G-band PLL settings implemented */
 +
- /* Values for SSB_SPROM1_BINF_CCODE */
- enum {
-       SSB_SPROM1CCODE_WORLD = 0,
++/* Values for boardflags_lo read from SPROM */
++#define SSB_BFL_BTCOEXIST             0x0001  /* implements Bluetooth coexistance */
+ #define SSB_BFL_PACTRL                        0x0002  /* GPIO 9 controlling the PA */
+ #define SSB_BFL_AIRLINEMODE           0x0004  /* implements GPIO 13 radio disable indication */
+ #define SSB_BFL_RSSI                  0x0008  /* software calculates nrssi slope. */
index 16a5a34ef05ba0a17c9c5c831e58c3f10ec79ddc..63ac069d6a0c768cf10cc7e337cda62e5637d4f7 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=omap4
 BOARDNAME:=TI OMAP4
 FEATURES:=usb targz audio display
 
 BOARDNAME:=TI OMAP4
 FEATURES:=usb targz audio display
 
-LINUX_VERSION:=3.2.2
+LINUX_VERSION:=3.2.5
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>