don't use the host strip command (closes: #592).
authorNicolas Thill <nico@openwrt.org>
Wed, 19 Jul 2006 06:46:38 +0000 (06:46 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 19 Jul 2006 06:46:38 +0000 (06:46 +0000)
SVN-Revision: 4163

openwrt/package/axtls/Makefile
openwrt/package/axtls/patches/002-strip.patch [new file with mode: 0644]

index 902797610848195d406d92f561f6e0f3fb64e19c..c53c4e5aea9927c60f9e5c1a113029c3dc07741c 100644 (file)
@@ -26,6 +26,7 @@ $(PKG_BUILD_DIR)/.configured:
 $(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC=$(TARGET_CC) \
+               STRIP=/bin/true \
                OPT_CFLAGS="$(TARGET_CFLAGS)" OPT_LDFLAGS=""
        touch $@
 
diff --git a/openwrt/package/axtls/patches/002-strip.patch b/openwrt/package/axtls/patches/002-strip.patch
new file mode 100644 (file)
index 0000000..95570b6
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ruN axTLS-0.95-old/httpd/Makefile axTLS-0.95-new/httpd/Makefile
+--- axTLS-0.95-old/httpd/Makefile      2006-02-28 02:50:28.000000000 +0100
++++ axTLS-0.95-new/httpd/Makefile      2006-05-18 22:24:02.000000000 +0200
+@@ -87,7 +87,7 @@
+       $(LD) $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
+ ifndef CONFIG_DEBUG
+ ifndef CONFIG_PLATFORM_SOLARIS
+-      strip --remove-section=.comment $(TARGET)
++      $(STRIP) --remove-section=.comment $(TARGET)
+ endif
+ endif
+ else    # Win32