[packages] taskwarrior: update to 2.0.0
authorLuka Perkov <luka@openwrt.org>
Sun, 10 Jun 2012 00:23:08 +0000 (00:23 +0000)
committerLuka Perkov <luka@openwrt.org>
Sun, 10 Jun 2012 00:23:08 +0000 (00:23 +0000)
SVN-Revision: 32154

utils/taskwarrior/Makefile

index 29af51e2c3344a82cec98bba564558f53d72c613..bdf74d480c1512d2c807835be1d2ea50b353a517 100644 (file)
@@ -1,31 +1,38 @@
 #
+# Copyright (C) 2012 OpenWrt.org
+#
 # This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
 include $(TOPDIR)/rules.mk
+
 PKG_NAME:=taskwarrior
-PKG_VERSION:=1.9.4
+PKG_VERSION:=2.0.0
+PKG_RELEASE:=1
+
 PKG_SOURCE:=task-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.taskwarrior.org/download/
-PKG_BUILD_DIR:=$(BUILD_DIR)/task-$(PKG_VERSION)
+PKG_MD5SUM:=b850b49f8b69bb4049c07d0914a0f7af
 
-PKG_RELEASE:=1
 PKG_INSTALL:=1
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/task-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
 
 define Package/taskwarrior
-       MAINTAINER:="Xiangfu Liu" <xiangfu@sharism.cc>
-       TITLE:=Taskwarrior - command line task manager
-       SECTION:=utils
-       CATEGORY:=Utilities
-       DEPENDS:=+libncurses
-       URL:=http://taskwarrior.org/projects/show/taskwarrior
+  TITLE:=taskwarrior
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libncurses
+  URL:=http://taskwarrior.org/projects/show/taskwarrior
+  MAINTAINER:=Xiangfu Liu <xiangfu@sharism.cc>
 endef
 
 define Package/taskwarrior/description
-       Taskwarrior is an ambitious project to supercharge task with an interactive interface, GTD features, color themes, data synch, dependencies,
-       custom reports, charts, and Lua plugins, all while our international team provides excellent support!
+ taskwarrior is a command-line todo list manager
 endef
 
 define Package/taskwarrior/install