do target dependent optimizations
authorImre Kaloz <kaloz@openwrt.org>
Mon, 14 Apr 2008 13:24:30 +0000 (13:24 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 14 Apr 2008 13:24:30 +0000 (13:24 +0000)
SVN-Revision: 10834

package/madwifi/Makefile
toolchain/Config.in

index 918424db2d9755ebd2ed058fb81e15abb0810a29..f2fdac7b9d7f6a665ad49e2e27cbc558528e2cd5 100644 (file)
@@ -39,10 +39,10 @@ endif
 ifeq ($(ARCH),i686)
   HAL_TARGET:=i386-elf
 endif
 ifeq ($(ARCH),i686)
   HAL_TARGET:=i386-elf
 endif
-ifeq ($(ARCH),armeb)
+ifeq ($(BOARD),ixp4xx)
   HAL_TARGET:=xscale-be-elf
 endif
   HAL_TARGET:=xscale-be-elf
 endif
-ifeq ($(ARCH),arm)
+ifeq ($(BOARD),iop32x)
   HAL_TARGET:=xscale-le-elf
 endif
 ifeq ($(ARCH),powerpc)
   HAL_TARGET:=xscale-le-elf
 endif
 ifeq ($(ARCH),powerpc)
index c4f6e14f57f9baba111c545b06e18a66109c13a8..1d7f1ab07a0cde5329c6b44006b23f4031429be7 100644 (file)
@@ -84,7 +84,7 @@ config TARGET_OPTIMIZATION
        default "-O2 -pipe -march=i486 -funit-at-a-time" if TARGET_x86
        default "-Os -pipe -march=i486 -funit-at-a-time" if TARGET_rdc
        default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" if mipsel || mips
        default "-O2 -pipe -march=i486 -funit-at-a-time" if TARGET_x86
        default "-Os -pipe -march=i486 -funit-at-a-time" if TARGET_rdc
        default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" if mipsel || mips
-       default "-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time" if armeb || arm
+       default "-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time" if TARGET_ixp4xx || TARGET_iop32x
        default "-Os -pipe -funit-at-a-time"
        help
          Optimizations to use when building for the target host.
        default "-Os -pipe -funit-at-a-time"
        help
          Optimizations to use when building for the target host.