Convert ntpclient to new packaging style
authorNicolas Thill <nico@openwrt.org>
Wed, 18 May 2005 13:30:05 +0000 (13:30 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 18 May 2005 13:30:05 +0000 (13:30 +0000)
SVN-Revision: 933

openwrt/package/ntpclient/Makefile
openwrt/package/ntpclient/files/S41ntpclient [deleted file]
openwrt/package/ntpclient/files/ntpclient.init [new file with mode: 0644]
openwrt/package/ntpclient/ipkg/ntpclient.control [new file with mode: 0644]
openwrt/package/ntpclient/ntpclient.control [deleted file]

index 23abdaaa71ad2f04f4fc5173cfd2c49423617c6b..02c0637766964a72f9560b75ec47913ee441e9ee 100644 (file)
@@ -7,38 +7,23 @@ PKG_MD5SUM:=94e84d5c6023c5e1f3890b28d0a08c92
 
 PKG_SOURCE_URL:=http://doolittle.faludi.com/ntpclient
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
-
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
-
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       touch $(PKG_BUILD_DIR)/.unpacked
-
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.unpacked
-       $(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)
-
-$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin $(PKG_IPK_DIR)/etc/init.d
-       install -m 755 $(PKG_BUILD_DIR)/ntpclient $(PKG_IPK_DIR)/usr/sbin/
-       install -m 755 ./files/S41ntpclient $(PKG_IPK_DIR)/etc/init.d/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
-
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,NTPCLIENT,ntpclient,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)"
+
+$(IPKG_NTPCLIENT):
+       install -d -m0755 $(IDIR_NTPCLIENT)/etc/init.d
+       install -m0755 ./files/ntpclient.init $(IDIR_NTPCLIENT)/etc/init.d/S41ntpclient
+       install -d -m0755 $(IDIR_NTPCLIENT)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/ntpclient $(IDIR_NTPCLIENT)/usr/sbin/
+       $(RSTRIP) $(IDIR_NTPCLIENT)
+       $(IPKG_BUILD) $(IDIR_NTPCLIENT) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/ntpclient/files/S41ntpclient b/openwrt/package/ntpclient/files/S41ntpclient
deleted file mode 100755 (executable)
index 16a75ca..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-/usr/sbin/ntpclient -c 1 -s -h pool.ntp.org
diff --git a/openwrt/package/ntpclient/files/ntpclient.init b/openwrt/package/ntpclient/files/ntpclient.init
new file mode 100644 (file)
index 0000000..16a75ca
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/sbin/ntpclient -c 1 -s -h pool.ntp.org
diff --git a/openwrt/package/ntpclient/ipkg/ntpclient.control b/openwrt/package/ntpclient/ipkg/ntpclient.control
new file mode 100644 (file)
index 0000000..c32e304
--- /dev/null
@@ -0,0 +1,6 @@
+Package: ntpclient
+Priority: optional
+Section: net
+Maintainer: Sebastien NOEL <me@twolife.org>
+Source: http://doolittle.faludi.com/ntpclient/
+Description: NTP client for setting system time from NTP servers.
diff --git a/openwrt/package/ntpclient/ntpclient.control b/openwrt/package/ntpclient/ntpclient.control
deleted file mode 100644 (file)
index c32e304..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: ntpclient
-Priority: optional
-Section: net
-Maintainer: Sebastien NOEL <me@twolife.org>
-Source: http://doolittle.faludi.com/ntpclient/
-Description: NTP client for setting system time from NTP servers.