Update nufw to 2.2.15 (#3642)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 13 Jul 2008 20:45:28 +0000 (20:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 13 Jul 2008 20:45:28 +0000 (20:45 +0000)
SVN-Revision: 11808

net/nufw/Makefile
net/nufw/patches/001-no_doc_tests.patch
net/nufw/patches/003-nuauth_install_dir.patch [deleted file]

index 599277bfd476d756f7e70cef3670ac4e19878eaf..29f428a89748259bc90dd0e5c6168c407f38dbf1 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nufw
-PKG_VERSION:=2.2.11
+PKG_VERSION:=2.2.15
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.nufw.org/download/nufw/
-PKG_MD5SUM:=ad7804254875fece7354b8749128df51
+PKG_MD5SUM:=ef9d335c2db263d85541379db7871f65
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
index 9f1f3681d19565199819b2bc901c0adfd7e4a5df..627446e3585354d2522165abe34d8d40a99e763f 100644 (file)
@@ -1,21 +1,21 @@
-diff -urN nufw-2.2.11/Makefile.am nufw-2.2.11.new/Makefile.am
---- nufw-2.2.11/Makefile.am    2007-12-08 12:08:50.000000000 +0100
-+++ nufw-2.2.11.new/Makefile.am        2008-02-05 12:10:08.000000000 +0100
+diff -urN nufw-2.2.15/Makefile.am nufw-2.2.15.new/Makefile.am
+--- nufw-2.2.15/Makefile.am    2008-04-15 14:12:18.000000000 +0200
++++ nufw-2.2.15.new/Makefile.am        2008-07-13 22:39:22.000000000 +0200
 @@ -1,4 +1,4 @@
--SUBDIRS = src scripts doc tests
-+SUBDIRS = src scripts
+-SUBDIRS = src scripts doc tests conf python
++SUBDIRS = src scripts conf python
  
- EXTRA_DIST = conf doc patches python debian autogen.sh
-diff -urN nufw-2.2.11/Makefile.in nufw-2.2.11.new/Makefile.in
---- nufw-2.2.11/Makefile.in    2008-01-08 22:35:41.000000000 +0100
-+++ nufw-2.2.11.new/Makefile.in        2008-02-05 12:09:47.000000000 +0100
+ PATCH_FILES = patches/dump-connection-mark.diff 
+ EXTRA_DIST = autogen.sh $(PATCH_FILES)
+diff -urN nufw-2.2.15/Makefile.in nufw-2.2.15.new/Makefile.in
+--- nufw-2.2.15/Makefile.in    2008-04-15 14:12:41.000000000 +0200
++++ nufw-2.2.15.new/Makefile.in        2008-07-13 22:39:40.000000000 +0200
 @@ -234,7 +234,7 @@
  sharedstatedir = @sharedstatedir@
  sysconfdir = @sysconfdir@
  target_alias = @target_alias@
--SUBDIRS = src scripts doc tests
-+SUBDIRS = src scripts 
- EXTRA_DIST = conf doc patches python debian autogen.sh
+-SUBDIRS = src scripts doc tests conf python
++SUBDIRS = src scripts conf python
+ PATCH_FILES = patches/dump-connection-mark.diff 
+ EXTRA_DIST = autogen.sh $(PATCH_FILES)
  all: all-recursive
diff --git a/net/nufw/patches/003-nuauth_install_dir.patch b/net/nufw/patches/003-nuauth_install_dir.patch
deleted file mode 100644 (file)
index 40eec10..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN nufw-2.2.11/src/nuauth/Makefile.am nufw-2.2.11.new/src/nuauth/Makefile.am
---- nufw-2.2.11/src/nuauth/Makefile.am 2007-12-18 14:11:10.000000000 +0100
-+++ nufw-2.2.11.new/src/nuauth/Makefile.am     2008-02-05 16:41:29.000000000 +0100
-@@ -27,7 +27,7 @@
- nuauth_LDADD = $(GLIB_LIBS) -lm  -lgnutls -lsasl2 -lnufw -L$(top_builddir)/src/include/
- install-exec-local:
--      install -d $(localstatedir)/run/nuauth/
-+      install -d $(DESTDIR)/$(localstatedir)/run/nuauth/
- nuauth$(EXEEXT): $(nuauth_OBJECTS) $(nuauth_DEPENDENCIES)
-       @rm -f nuauth$(EXEEXT)