replace the ugly rb532 cmdline hack with a cleaner one that does not depend on magic...
authorFelix Fietkau <nbd@openwrt.org>
Wed, 6 Dec 2006 18:31:28 +0000 (18:31 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 6 Dec 2006 18:31:28 +0000 (18:31 +0000)
SVN-Revision: 5699

target/linux/rb532-2.6/base-files.mk [new file with mode: 0644]
target/linux/rb532-2.6/base-files/sbin/cf2nand
target/linux/rb532-2.6/image/Makefile
target/linux/rb532-2.6/patches/140-cmdline_hack.patch
target/linux/rb532-2.6/src/patch-cmdline.c [new file with mode: 0644]

diff --git a/target/linux/rb532-2.6/base-files.mk b/target/linux/rb532-2.6/base-files.mk
new file mode 100644 (file)
index 0000000..afd1220
--- /dev/null
@@ -0,0 +1,11 @@
+define Build/Compile
+       $(call Build/Compile/Default)
+       $(TARGET_CC) -o $(PKG_BUILD_DIR)/patch-cmdline $(PLATFORM_DIR)/src/patch-cmdline.c
+endef
+
+define Package/base-files/install-target
+       mkdir -p $(1)/sbin
+       $(CP) $(PKG_BUILD_DIR)/patch-cmdline $(1)/sbin
+endef
+
+
index f8576beaa4ec692f28286d4e4d322f8828ee3713..3f3352fd1b566503215f6a283ced1dd22cefb664 100755 (executable)
@@ -6,13 +6,8 @@ copy_kernel() {
        local output="$2"
        local cmdline="$3"
        size="$(echo -n "$cmdline" | wc -c)"
-       dd if="$input" bs=3M count=1 | (
-               dd bs=4112 count=1
-               echo -n "$cmdline"
-               dd if=/dev/zero bs="$((512 - $size))" count=1
-               dd bs=512 count=1 of=/dev/null
-               cat
-       ) > "$output"
+       dd if="$input" bs=3M count=1 > "$output"
+       /sbin/patch-cmdline "$output" "$cmdline"
 }
 
 fstype="$(mount | grep ' / ' | awk '{print $5}')"
index 27e4357a8336d94919d34eebb4d6193f904b3d00..49072144692dcc7da46ae556f7df244be7e983f0 100644 (file)
@@ -20,17 +20,16 @@ LOADER_MAKEOPTS= \
                RAMSIZE=$(RAMSIZE) \
                IMAGE_COPY=$(IMAGE_COPY)
 
+define Build/Compile
+       $(CC) -o $(STAGING_DIR)/bin/patch-cmdline $(PLATFORM_DIR)/src/patch-cmdline.c
+endef
+
 define Build/Clean
        $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
 endef
 
-CMDLINE_SIZE=512
-CMDLINE_OFFSET=4112
-
 define Image/Prepare
-       echo 'root=/dev/cfa2 ' | \
-               dd bs=$(CMDLINE_SIZE) count=1 conv=sync | \
-               dd of=$(LINUX_DIR)/vmlinux bs=$(CMDLINE_OFFSET) conv=notrunc seek=1
+       $(STAGING_DIR)/bin/patch-cmdline $(LINUX_DIR)/vmlinux 'root=/dev/cfa2 '
        $(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
 endef
 
@@ -56,9 +55,7 @@ root=/dev/cfa2 rootfstype=ext2
 endef
 
 define Image/Build
-       echo '$(strip $(call Image/cmdline/$(1))) ' | \
-               dd bs=$(CMDLINE_SIZE) count=1 conv=sync | \
-               dd of=$(LINUX_DIR)/vmlinux bs=$(CMDLINE_OFFSET) conv=notrunc seek=1
+       $(STAGING_DIR)/bin/patch-cmdline $(LINUX_DIR)/vmlinux '$(strip $(call Image/cmdline/$(1))) '
        ( \
                echo -ne OWRT | dd bs=$$$$((0x1be)) conv=sync; \
                ( \
index 55cf8889f65a14a1bc746607fadd2d587c45c6aa..01daf3132c068c4a9c4c95567b573c8c9a30d763 100644 (file)
@@ -1,18 +1,33 @@
 diff -ur linux.old/arch/mips/kernel/head.S linux.dev/arch/mips/kernel/head.S
---- linux.old/arch/mips/kernel/head.S  2006-10-26 00:11:13.000000000 +0200
-+++ linux.dev/arch/mips/kernel/head.S  2006-10-26 02:40:10.000000000 +0200
-@@ -132,6 +132,8 @@
+--- linux.old/arch/mips/kernel/head.S  2006-12-06 17:30:27.000000000 +0100
++++ linux.dev/arch/mips/kernel/head.S  2006-12-06 18:34:43.000000000 +0100
+@@ -129,15 +129,20 @@
+ #endif
+       .endm
  
+-
        j kernel_entry
        nop
+-
 +      nop
-+EXPORT(_image_cmdline)
++      
        /*
         * Reserved space for exception handlers.
+        * Necessary for machines which link their kernels at KSEG0.
++       * Use as temporary storage for the kernel command line, so that it
++       * can be updated easily without having to relink the kernel.
+        */
+-      .fill   0x400
++       
++EXPORT(_image_cmdline)
++      .ascii "CMDLINE:"
++      .fill   0x3ec
+ EXPORT(stext)                                 # used for profiling
+ EXPORT(_stext)
 diff -ur linux.old/arch/mips/rb500/prom.c linux.dev/arch/mips/rb500/prom.c
---- linux.old/arch/mips/rb500/prom.c   2006-10-26 00:11:14.000000000 +0200
-+++ linux.dev/arch/mips/rb500/prom.c   2006-10-26 02:40:46.000000000 +0200
+--- linux.old/arch/mips/rb500/prom.c   2006-12-06 17:30:27.000000000 +0100
++++ linux.dev/arch/mips/rb500/prom.c   2006-12-06 17:41:40.000000000 +0100
 @@ -128,6 +128,7 @@
        /* FIXME: STUB */
  }
@@ -26,7 +41,7 @@ diff -ur linux.old/arch/mips/rb500/prom.c linux.dev/arch/mips/rb500/prom.c
                cp+=strlen(prom_argv[i]);
        }
 +      *(cp++) = ' ';
-+      strcpy(cp,&_image_cmdline);
++      strcpy(cp,(&_image_cmdline + 8));
 +      cp += strlen(&_image_cmdline);
        
        i=strlen(arcs_cmdline);
diff --git a/target/linux/rb532-2.6/src/patch-cmdline.c b/target/linux/rb532-2.6/src/patch-cmdline.c
new file mode 100644 (file)
index 0000000..d4636f7
--- /dev/null
@@ -0,0 +1,80 @@
+/*
+ * patch-cmdline.c - patch the kernel command line on rb532
+ *
+ * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+ *
+ * $Id:$
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <stddef.h>
+#include <unistd.h>
+#include <fcntl.h>
+#include <sys/mman.h>
+#include <sys/stat.h>
+#include <string.h>
+
+#define SEARCH_SPACE   (16 * 1024)
+#define CMDLINE_MAX            512
+
+int main(int argc, char **argv)
+{
+       int fd, found = 0, len, ret = -1;
+       char *ptr, *p;
+
+       if (argc != 3) {
+               fprintf(stderr, "Usage: %s <file> <cmdline>\n", argv[0]);
+               goto err1;
+       }
+       len = strlen(argv[2]);
+       if (len + 9 > CMDLINE_MAX) {
+               fprintf(stderr, "Command line string too long\n");
+               goto err1;
+       }
+       
+       if (((fd = open(argv[1], O_RDWR)) < 0) ||
+               (ptr = (char *) mmap(0, SEARCH_SPACE + CMDLINE_MAX, PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0)) == (void *) (-1)) {
+               fprintf(stderr, "Could not open kernel image");
+               goto err2;
+       }
+       
+       for (p = ptr; p < (ptr + SEARCH_SPACE); p += 4) {
+               if (memcmp(p, "CMDLINE:", 8) == 0) {
+                       found = 1;
+                       p += 8;
+                       break;
+               }
+       }
+       if (!found) {
+               fprintf(stderr, "Command line marker not found!\n");
+               goto err3;
+       }
+
+       memset(p, 0, CMDLINE_MAX - 8);
+       strcpy(p, argv[2]);
+       msync(p, CMDLINE_MAX, MS_SYNC|MS_INVALIDATE);
+       ret = 0;
+
+err3:
+       munmap((void *) ptr, len);
+err2:
+       if (fd > 0)
+               close(fd);
+err1:
+       return ret;
+}