enable jpeg support, add dependency on libpng, standardize.
authorNicolas Thill <nico@openwrt.org>
Fri, 3 Feb 2006 08:31:25 +0000 (08:31 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 3 Feb 2006 08:31:25 +0000 (08:31 +0000)
SVN-Revision: 3121

openwrt/package/libgd/Config.in
openwrt/package/libgd/Makefile
openwrt/package/libgd/ipkg/libgd.control

index 4d1efda80eeee946ed406bc520111e912c582926..8c513bda78a5c060075ead16422fc8d83a2c88f8 100644 (file)
@@ -2,6 +2,8 @@ config BR2_PACKAGE_LIBGD
        prompt "libgd............................. The GD Graphics Library"
        tristate
        default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBJPEG
+       select BR2_PACKAGE_LIBPNG
        help
          The GD Graphics Library
          
index 0d31287df028ce09cf38b9845565f1450c166d2c..88933e702114692760ce25dd9196bff645ccfd40 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gd
 PKG_VERSION:=2.0.33
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=be0a6d326cd8567e736fbc75df0a5c45
 
 PKG_SOURCE_URL:=http://www.boutell.com/gd/http
@@ -26,34 +26,34 @@ $(PKG_BUILD_DIR)/.configured:
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                LIBPNG12_CONFIG="$(STAGING_DIR)/usr/bin/libpng12-config" \
                ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib \
-                 --localstatedir=/var \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
-                 $(DISABLE_LARGEFILE) \
-                 $(DISABLE_NLS) \
-                 --enable-shared \
-                 --enable-static \
-                 --disable-rpath \
-                 --with-gnu-ld \
-                 --without-x \
-                 --without-freetype \
-                 --without-jpeg \
-                 --with-png=$(STAGING_DIR)/usr \
-                 --without-xpm \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
+                       --without-x \
+                       --without-freetype \
+                       --with-jpeg=$(STAGING_DIR)/usr \
+                       --with-png=$(STAGING_DIR)/usr \
+                       --without-xpm \
        )
        touch $@
 
index bd19d9e8fe337e0d109aaefbe39674426d3bafa1..f6a78e5c3af0285c1678ce5eac46df732a7dfc96 100644 (file)
@@ -1,5 +1,5 @@
 Package: libgd
 Priority: optional
 Section: libs
-Depends: libpng
+Depends: libjpeg, libpng
 Description: A library for the dynamic creation of images