Add tftp-hpa (#928)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 9 Nov 2006 20:34:59 +0000 (20:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 9 Nov 2006 20:34:59 +0000 (20:34 +0000)
SVN-Revision: 5487

net/tftp-hpa/Makefile [new file with mode: 0644]
net/tftp-hpa/files/tftpd-hpa.init [new file with mode: 0644]

diff --git a/net/tftp-hpa/Makefile b/net/tftp-hpa/Makefile
new file mode 100644 (file)
index 0000000..2607d57
--- /dev/null
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 5348 2006-10-30 13:51:50Z nico $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tftp-hpa
+PKG_VERSION:=0.43
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/software/network/tftp
+PKG_MD5SUM:=
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/tftp-hpa
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=tftp-hpa is an enhanced version of the BSD TFTP client
+ URL:=http://www.kernel.org/pub/software/network/tftp
+endef
+
+define Package/tftpd-hpa
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=tftp-hpa is an enhanced version of the BSD TFTP server
+ URL:=http://www.kernel.org/pub/software/network/tftp
+endef
+
+define Build/Configure 
+       $(call Build/Configure/Default)
+endef
+
+define Build/Compile   
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Package/tftp-hpa/install        
+       install -d -m0755 $(1)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/tftp/tftp $(1)/usr/bin/tftp-hpa
+endef
+
+define Package/tftpd-hpa/install
+       install -d -m0755 $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/tftpd/tftpd $(1)/usr/sbin/tftpd-hpa
+       install -d -m0755 $(1)/etc/init.d
+       install -m0755 ./files/tftpd-hpa.init $(1)/etc/init.d/tftpd-hpa
+endef
+
+$(eval $(call BuildPackage,tftp-hpa))
+$(eval $(call BuildPackage,tftpd-hpa))
diff --git a/net/tftp-hpa/files/tftpd-hpa.init b/net/tftp-hpa/files/tftpd-hpa.init
new file mode 100644 (file)
index 0000000..0970da2
--- /dev/null
@@ -0,0 +1,12 @@
+#!/bin/sh /etc/rc.common
+
+RUN_D=/var/tftpd-hpa
+
+start() {
+       [ -d $RUN_D ] || mkdir -p $RUN_D
+       tftpd-hpa -l -s $RUN_D
+}
+
+stop() {
+       killall tftpd-hpa
+}