ar71xx: image: use the MultiProfile helper for the Madwifi profile
authorGabor Juhos <juhosg@openwrt.org>
Thu, 23 Aug 2012 13:11:25 +0000 (13:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 23 Aug 2012 13:11:25 +0000 (13:11 +0000)
SVN-Revision: 33262

target/linux/ar71xx/image/Makefile

index 58b3173de40e47da5b75df9cb48b85f9ace87b37..c0a1a9d6c628c2e05f6b25afbd046a3fe63266eb 100644 (file)
@@ -887,14 +887,7 @@ $(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H516,zcn-1523h-5-16,ZCN-1523
 
 $(eval $(call MultiProfile,Default,$(SINGLE_PROFILES)))
 $(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
 
 $(eval $(call MultiProfile,Default,$(SINGLE_PROFILES)))
 $(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
-
-define Image/Build/Profile/Madwifi
-       $(call Image/Build/Profile/EAP7660D,$(1))
-       $(call Image/Build/Profile/UBNTRS,$(1))
-       $(call Image/Build/Profile/UBNTRSPRO,$(1))
-       $(call Image/Build/Profile/UBNTLSSR71,$(1))
-       $(call Image/Build/Profile/WP543,$(1))
-endef
+$(eval $(call MultiProfile,Madwifi,EAP7660D UBNTRS UBNTRSPRO UBNTLSSR71 WP543))
 
 define Image/Build/squashfs
        cp $(KDIR)/root.squashfs $(KDIR)/root.squashfs-raw
 
 define Image/Build/squashfs
        cp $(KDIR)/root.squashfs $(KDIR)/root.squashfs-raw