[package] globally define IPv6 support or not in OpenWrt, just like for largefiles...
authorFlorian Fainelli <florian@openwrt.org>
Sat, 25 Jul 2009 21:45:51 +0000 (21:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 25 Jul 2009 21:45:51 +0000 (21:45 +0000)
SVN-Revision: 16983

Config.in
include/package-defaults.mk
rules.mk

index d7ce63e462c86991787164e4659839677fc62b5e..18aafda3a735d94a7d866d714f3ae5ef808937a4 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -142,6 +142,13 @@ config DEBUG_DIR
                This will install all compiled package binaries into build_dir/target-*/debug-*/,
                useful for cross-debugging via gdb/gdbserver
 
                This will install all compiled package binaries into build_dir/target-*/debug-*/,
                useful for cross-debugging via gdb/gdbserver
 
+config IPV6 
+        bool 
+        prompt "Enable IPv6 support in packages"
+        default n 
+        help 
+                Enable IPV6 support in packages (passes --enable-ipv6 to configure scripts).
+
 comment "Kernel build options"
 
 config KERNEL_KALLSYMS
 comment "Kernel build options"
 
 config KERNEL_KALLSYMS
index 753c10227e9ecdcabc57cf7a80ea2140ebf0a4f3..3cba736f0f101d282b4033d1056ebe97f4836e11 100644 (file)
@@ -60,7 +60,9 @@ CONFIGURE_ARGS = \
                --localstatedir=/var \
                --mandir=$(CONFIGURE_PREFIX)/man \
                --infodir=$(CONFIGURE_PREFIX)/info \
                --localstatedir=/var \
                --mandir=$(CONFIGURE_PREFIX)/man \
                --infodir=$(CONFIGURE_PREFIX)/info \
-               $(DISABLE_NLS)
+               $(DISABLE_NLS) \
+               $(DISABLE_LARGEFILE) \
+               $(DISABLE_IPV6)
 
 CONFIGURE_VARS = \
                $(TARGET_CONFIGURE_OPTS) \
 
 CONFIGURE_VARS = \
                $(TARGET_CONFIGURE_OPTS) \
index 05609b9ac03afaec2df13fae2d1d214ec9f89ee1..3f39eefd7b6320c21495bc05560e7d40875009fb 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -153,13 +153,21 @@ else
 endif
 
 ifeq ($(CONFIG_ENABLE_LOCALE),true)
 endif
 
 ifeq ($(CONFIG_ENABLE_LOCALE),true)
-  DISABLE_NLS:=
+  DISABLE_NLS:=--enable-nls
 else
   DISABLE_NLS:=--disable-nls
 endif
 
 else
   DISABLE_NLS:=--disable-nls
 endif
 
-ifneq ($(CONFIG_LARGEFILE),y)
-  DISABLE_LARGEFILE= --disable-largefile
+ifeq ($(CONFIG_IPV6),y)
+  DISABLE_IPV6:=--enable-ipv6
+else
+  DISABLE_IPV6:=--disable-ipv6
+endif
+
+ifeq ($(CONFIG_LARGEFILE),y)
+  DISABLE_LARGEFILE:=
+else
+  DISABLE_LARGEFILE:=--disable-largefile
 endif
 
 ifeq ($(CONFIG_TAR_VERBOSITY),y)
 endif
 
 ifeq ($(CONFIG_TAR_VERBOSITY),y)