move in Python submenu, misc cosmetic changes
authorNicolas Thill <nico@openwrt.org>
Mon, 14 Apr 2008 01:06:00 +0000 (01:06 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 14 Apr 2008 01:06:00 +0000 (01:06 +0000)
SVN-Revision: 10825

lang/egenix-mx/Makefile
lang/kid/Makefile
lang/psycopg/Makefile
lang/pyevent/Makefile
lang/pymysql/Makefile
lang/pypcap/Makefile
lang/pysqlite/Makefile
lang/twisted/Makefile
lang/yapsnmp/Makefile

index 496de826e25d73387c3b0e398b4bee17cd77bffb..7e5001b2a62fbfdc889f527b8a8090c915bc88a5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -26,6 +26,7 @@ ifneq ($(MAKECMDGOALS),download)
 endif
 
 define Package/python-egenix-mx
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   DEPENDS:=python-core
index 139cbad5eaca432bdd38ba455032c3f4fb951ee6..0e93eeeb3ed69addf9e6df6e8ae0287a32b33f58 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kid-templating.org/dist/0.9.6/dist
 PKG_MD5SUM:=31e7156698a6f214b4067afb9e13728f
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,6 +25,7 @@ ifneq ($(MAKECMDGOALS),download)
 endif
 
 define Package/python-kid
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   DEPENDS:=python-core
index a1f32248fbea87dd8c6f5b33aa185067a0ff5fac..288b754964f2e509ae3e3a588405e1f660e5ddad 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.initd.org/pub/software/psycopg/
 PKG_MD5SUM:=a31f79f68d6d32898d6f24e11369a106
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,6 +25,7 @@ ifneq ($(MAKECMDGOALS),download)
 endif
 
 define Package/python-psycopg
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=PostgreSQL database adapter for Python
index 0a48e49d0420d2898f4703ff564c488b7824beb2..01d93a4c26dec7ad16416ab12ddc38f9e5abf5ec 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://pyevent.googlecode.com/files/
 PKG_MD5SUM:=584912c92d08bf005283fb29a47a6e4d
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,6 +25,7 @@ ifneq ($(MAKECMDGOALS),download)
 endif
 
 define Package/python-event
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Python interface to libevent
index 2375f6faa935361fa2e05949b7ab2bfda9cbb6b9..c0b6701c6092ad36ad1ce0ab25d4e4812e4bb9c3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mysql-python
 PKG_MD5SUM:=532268f02870bea18c1d465e88afff30
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,6 +25,7 @@ ifneq ($(MAKECMDGOALS),download)
 endif
 
 define Package/python-mysql
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=MySQL database adapter for Python
index ba7933f34292ca16171ae96e00f29bd4ef1fd3f8..23d6645e692fb5687a3128fc763433090a0dca1b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://pypcap.googlecode.com/files
 PKG_MD5SUM:=034c3cbbfa81aa19e8f685b767c65764
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,6 +25,7 @@ ifneq ($(MAKECMDGOALS),download)
 endif
 
 define Package/python-pcap
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Python interface to lipcap
index e9431198efad770094c5149525e1bed92d92e9be..b1629fbf5b6d28e90d57b822d5dd59b382d30cb7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://initd.org/pub/software/pysqlite/releases/2.3/2.3.5/
 PKG_MD5SUM:=b4a185e936848370fcc1a5b17755b641
+
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,9 +25,12 @@ ifneq ($(MAKECMDGOALS),download)
 endif
 
 define Package/python-sqlite
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
  TITLE:=SQLite database adapter for Python
  URL:=http://www.initd.org/tracker/pysqlite/wiki/pysqlite
- DEPENDS:= +libsqlite3
+ DEPENDS:=python-core +libsqlite3
 endef
 
 define Package/python-sqlite/description
index 6cab30276aa6aa3fa3eb603f7dbcdc9c7feaed8a..03a557634a0141ea3742313ced64740cf0021e30 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -26,10 +26,11 @@ ifneq ($(MAKECMDGOALS),download)
 endif
 
 define Package/twisted/default
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
-  DEPENDS:=python-core
   URL:=http://twistedmatrix.com/
+  DEPENDS:=python-core
 endef
 
 define Package/twisted/default/description
index b9404c06f1cafaee0acbc12723e64e93ecc86824..ce597c1c1101edcdc2a4f3c523fd0e5e0aabebd5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_MD5SUM:=8a3e9a5b814388d7907c639105cb2365
+
 PKG_BUILD_DEPENDS:=python
 
 PKG_FIXUP = libtool
@@ -26,6 +27,7 @@ ifneq ($(MAKECMDGOALS),download)
 endif
 
 define Package/python-yapsnmp
+  SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Python interface to Net-SNMP