[package] add curlftpfs (#5950)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jan 2010 16:02:08 +0000 (16:02 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jan 2010 16:02:08 +0000 (16:02 +0000)
SVN-Revision: 19006

net/curlftpfs/Makefile [new file with mode: 0644]
net/curlftpfs/patches/001-uclibc_mod.patch [new file with mode: 0644]

diff --git a/net/curlftpfs/Makefile b/net/curlftpfs/Makefile
new file mode 100644 (file)
index 0000000..37c55fe
--- /dev/null
@@ -0,0 +1,38 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=curlftpfs
+PKG_VERSION:=0.9.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/curlftpfs
+PKG_MD5SUM:=b452123f755114cd4461d56c648d9f12
+
+PKG_BUILD_DEPENDS:=libiconv
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/curlftpfs
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libcurl +libfuse +glib2
+  TITLE:=CurlFtpFS
+endef
+
+define Package/curlftpfs/description
+  CurlFtpFS is a filesystem for accessing FTP hosts
+  based on FUSE and libcurl.
+endef
+
+EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/lib/libiconv/include -DICONV_CONST=const
+
+define Package/curlftpfs/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/curlftpfs $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,curlftpfs))
+
diff --git a/net/curlftpfs/patches/001-uclibc_mod.patch b/net/curlftpfs/patches/001-uclibc_mod.patch
new file mode 100644 (file)
index 0000000..8eb1556
--- /dev/null
@@ -0,0 +1,37 @@
+diff -cr curlftpfs-0.9.2/ftpfs-ls.c curlftpfs-0.9.2-1/ftpfs-ls.c
+*** curlftpfs-0.9.2/ftpfs-ls.c 2008-04-23 12:55:41.000000000 +0200
+--- curlftpfs-0.9.2-1/ftpfs-ls.c       2009-09-24 23:19:03.000000000 +0200
+***************
+*** 58,64 ****
+                 "%5s"  "%*c"
+                 "%1023c",
+                 mode, &nlink, user, group, &size, month, day, year, file);
+!   if (res < 9) {
+      res = sscanf(line,
+                   "%11s"
+                   "%32s" SPACES
+--- 58,64 ----
+                 "%5s"  "%*c"
+                 "%1023c",
+                 mode, &nlink, user, group, &size, month, day, year, file);
+!   if (res < 8) {
+      res = sscanf(line,
+                   "%11s"
+                   "%32s" SPACES
+***************
+*** 69,75 ****
+                   "%5s"  "%*c"
+                   "%1023c",
+                   mode, user, group, &size, month, day, year, file);
+!     if (res < 8) {
+        return 0;
+      }
+    }
+--- 69,75 ----
+                   "%5s"  "%*c"
+                   "%1023c",
+                   mode, user, group, &size, month, day, year, file);
+!     if (res < 7) {
+        return 0;
+      }
+    }