uob-nomad: clean the tree to avoid packaging precompiled binaries, fix passing openwr...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 11 Jun 2012 23:30:15 +0000 (23:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 11 Jun 2012 23:30:15 +0000 (23:30 +0000)
SVN-Revision: 32234

net/uob-nomad/Makefile

index 8435dac2bbc668573fc32ee0c9fa5826883707bb..cdf673c139936b1fe5408554772371bfe8986350 100644 (file)
@@ -38,12 +38,15 @@ This is an implementation of NOMADv4 (Filters for
        status information to the UoB-NOMAD-GUI (ver 0.1).
 endef
 
+MAKE_FLAGS = \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS)"
+
 define Build/Compile
-$(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Agent mipagent)
+$(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Agent clean mipagent)
 $(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client/net-tools clean)
 $(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client/net-tools/lib clean)
 $(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client/net-tools all)
-$(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client mipmn)
+$(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client clean mipmn)
 endef
 
 define Package/uob-nomad/install