net/lsm: Upgrade to new upstream version 0.60. (thank you Brian J. Murrell)
authorAlexandros C. Couloumbis <alex@ozo.com>
Wed, 13 Oct 2010 09:09:43 +0000 (09:09 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Wed, 13 Oct 2010 09:09:43 +0000 (09:09 +0000)
SVN-Revision: 23422

net/lsm/Makefile
net/lsm/files/lsm.conf
net/lsm/files/lsm.init

index 1aa3d2d22415de29836b3f118e1b9e2cd1087ce4..7fd0faa9b3004950fae2bd28847543c3b479b606 100644 (file)
@@ -8,15 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lsm
-PKG_VERSION:=0.53
+PKG_VERSION:=0.60
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://lsm.foobar.fi/download
-PKG_MD5SUM:=983911b434a3c649fcefdc99e6ea2f37
+PKG_MD5SUM:=f4748308c0a1caa98d7e756778954116
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_UNPACK += && rmdir $(PKG_BUILD_DIR) && mv $(BUILD_DIR)/lsm $(PKG_BUILD_DIR)
+
 define Package/lsm
   SECTION:=net
   CATEGORY:=Network
@@ -34,12 +36,6 @@ define Package/lsm/conffiles
 /etc/lsm/lsm.conf
 endef
 
-define Build/Prepare
-       $(call Build/Prepare/Default)
-       rmdir $(PKG_BUILD_DIR)
-       mv $(BUILD_DIR)/lsm $(PKG_BUILD_DIR)
-endef
-
 define Build/Compile
        echo sed -ie 's/\$$$$(CC)/mipsel-openwrt-linux-uclibc-gcc/g' $(PKG_BUILD_DIR)/Makefile
        $(MAKE) -C $(PKG_BUILD_DIR) CC=$(TARGET_CC)
index ce54cea6b542190dfa91c5142e2a41788772b96e..16f9d04ad518e713254215404b51a4e9f37ec2d5 100644 (file)
@@ -12,6 +12,7 @@
 #debug=10
 #debug=9
 debug=8
+reopen_on_enodev=1
 
 #
 # Defaults for the connection entries
index e9d31622044288273924f294f209f68bfa33f4fe..d1ca4fff730b28cb940693198c419acdaf1e4e10 100644 (file)
@@ -1,12 +1,44 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-START=50
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+NAME=lsm
+PROG=/usr/sbin/$NAME
+DESC="Link State Monitor"
+PIDFILE=/var/run/lsm.pid
+START=45
+
+test -x $PROG || exit 0
+set -e
 
 start() {
-       lsm /etc/lsm/lsm.conf
+       echo -n "Starting $DESC: $NAME"
+       start-stop-daemon -q -S -p $PIDFILE -x $PROG -- /etc/lsm/lsm.conf $PIDFILE
+
+       echo "."
 }
 
 stop() {
-       killall lsm
+       echo -n "Stopping $DESC: $NAME"
+       start-stop-daemon -q -K -p $PIDFILE -x $PROG -- /etc/lsm/lsm.conf $PIDFILE
+       echo "."
 }
 
+restart() {
+       echo -n "Restarting $DESC: $NAME... "
+       start-stop-daemon -q -K -p $PIDFILE -x $PROG -- /etc/lsm/lsm.conf $PIDFILE
+       sleep 1
+       start-stop-daemon -q -S -p $PIDFILE -x $PROG -- /etc/lsm/lsm.conf $PIDFILE
+       echo "done."
+}
+
+reload() {
+       #
+       #       If the daemon can reload its config files on the fly
+       #       for example by sending it SIGHUP, do it here.
+       #
+       #       If the daemon responds to changes in its config file
+       #       directly anyway, make this a do-nothing entry.
+       #
+       echo -n "Reloading $DESC configuration... "
+       start-stop-daemon -q -K -s HUP -p $PIDFILE -x $PROG -- /etc/lsm/lsm.conf $PIDFILE
+       echo "done."
+}