add libxml2 package
authorNicolas Thill <nico@openwrt.org>
Sun, 14 Aug 2005 06:41:39 +0000 (06:41 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 14 Aug 2005 06:41:39 +0000 (06:41 +0000)
SVN-Revision: 1657

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/libxml2/Config.in [new file with mode: 0644]
openwrt/package/libxml2/Makefile [new file with mode: 0644]
openwrt/package/libxml2/ipkg/libxml2.control [new file with mode: 0644]

index 1364efd9900f2eb2ecc6ac46b24dcec7e6d1664e..96d6f154b84965820493420761775f75cb39319e 100644 (file)
@@ -145,6 +145,7 @@ source "package/sqlite/Config.in" # libsqlite
 source "package/sqlite2/Config.in" # libsqlite2
 source "package/libtasn1/Config.in"
 source "package/libusb/Config.in"
+source "package/libxml2/Config.in"
 source "package/uclibc++/Config.in"
 source "package/zlib/Config.in"
 source "package/irssi/Config.in"
index fd06b9f587b609245d760a0df9b27ceb7dbc4ca5..2c7bc28431dba3f24240fbe8b80bc3fb3888381e 100644 (file)
@@ -72,6 +72,7 @@ package-$(BR2_PACKAGE_LIBPTHREAD) += libpthread
 package-$(BR2_PACKAGE_LIBTASN1) += libtasn1
 package-$(BR2_PACKAGE_LIBTOOL) += libtool
 package-$(BR2_PACKAGE_LIBUSB) += libusb
+package-$(BR2_PACKAGE_LIBXML2) += libxml2
 package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
 package-$(BR2_PACKAGE_LINUX_ATM) += linux-atm
 package-$(BR2_PACKAGE_LUA) += lua
@@ -187,6 +188,7 @@ libgcrypt-compile: libgpg-error-compile
 libgd-compile: libpng-compile
 libnet-compile: libpcap-compile
 libnids-compile: libnet-compile
+libxml2-compile: zlib-compile
 lighttpd-compile: openssl-compile pcre-compile
 mini_httpd-compile: matrixssl-compile
 mysql-compile: ncurses-compile zlib-compile
diff --git a/openwrt/package/libxml2/Config.in b/openwrt/package/libxml2/Config.in
new file mode 100644 (file)
index 0000000..3230b2f
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBXML2
+       tristate "libxml2 - Gnome XML library"
+#      default m if CONFIG_DEVEL
+       default n
+       select BR2_PACKAGE_LIBPTHREAD
+       select BR2_PACKAGE_ZLIB
+       help
+         A library for manipulating XML and HTML resources.
+         
+         http://xmlsoft.org/
+         
diff --git a/openwrt/package/libxml2/Makefile b/openwrt/package/libxml2/Makefile
new file mode 100644 (file)
index 0000000..a3c6e00
--- /dev/null
@@ -0,0 +1,122 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libxml2
+PKG_VERSION:=2.6.20
+PKG_RELEASE:=1
+PKG_MD5SUM:=8f0b3ce721bda11401e656b90ba4e78c
+
+PKG_SOURCE_URL:=http://xmlsoft.org/sources/ \
+       ftp://fr.rpmfind.net/pub/libxml/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBXML2,libxml2,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(strip $(TARGET_CFLAGS))" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
+                       --without-c14n \
+                       --without-catalog \
+                       --without-debug \
+                       --without-docbook \
+                       --without-html \
+                       --without-ftp \
+                       --without-http \
+                       --without-iconv \
+                       --without-iso8859x \
+                       --without-legacy \
+                       --with-output \
+                       --without-pattern \
+                       --without-push \
+                       --without-python \
+                       --with-reader \
+                       --without-readline \
+                       --without-regexps \
+                       --with-sax1 \
+                       --with-schemas \
+                       --with-threads \
+                       --with-tree \
+                       --with-valid \
+                       --with-writer \
+                       --without-xinclude \
+                       --without-xpath \
+                       --without-xptr \
+                       --with-zlib \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_LIBXML2):
+       install -m0755 -d $(IDIR_LIBXML2)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libxml2.so.* $(IDIR_LIBXML2)/usr/lib/
+       $(RSTRIP) $(IDIR_LIBXML2)
+       $(IPKG_BUILD) $(IDIR_LIBXML2) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/libxml2.so: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/xml2-config $(STAGING_DIR)/usr/bin/
+       mkdir -p $(STAGING_DIR)/usr/include
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/libxml2 $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libxml2.{a,so*} $(STAGING_DIR)/usr/lib/
+       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxml-2.0.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/libxml2.so
+
+uninstall-dev:
+       rm -rf \
+               $(STAGING_DIR)/usr/bin/libxml2-config \
+               $(STAGING_DIR)/usr/include/libxml2 \
+               $(STAGING_DIR)/usr/lib/libxml2.{a,so*} \
+               $(STAGING_DIR)/usr/lib/pkgconfig/libxml-2.0.pc \
+
+compile: install-dev
+clean: uninstall-dev
+
+mostlyclean:
+       make -C $(PKG_BUILD_DIR) clean
+       rm $(PKG_BUILD_DIR)/.built
+
diff --git a/openwrt/package/libxml2/ipkg/libxml2.control b/openwrt/package/libxml2/ipkg/libxml2.control
new file mode 100644 (file)
index 0000000..383a4d0
--- /dev/null
@@ -0,0 +1,9 @@
+Package: libxml2
+Priority: optional
+Section: libs
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/libxml2/
+Description: Gnome XML library
+Depends: zlib