generic/3.18: upgrade to 3.18.10
authorImre Kaloz <kaloz@openwrt.org>
Tue, 31 Mar 2015 19:21:13 +0000 (19:21 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 31 Mar 2015 19:21:13 +0000 (19:21 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 45197

include/kernel-version.mk
target/linux/generic/patches-3.18/643-bridge_remove_ipv6_dependency.patch
target/linux/generic/patches-3.18/701-phy_extension.patch
target/linux/mvebu/patches-3.18/210-xhci_move_marvell_quirks.patch [deleted file]

index 16f76e7611ec597d977829d2704f00fee95b43e6..6421acb4559d93364d698738cf2d01ba6457c1fe 100644 (file)
@@ -6,14 +6,14 @@ LINUX_VERSION-3.8  = .13
 LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
 LINUX_VERSION-3.14 = .35
-LINUX_VERSION-3.18 = .9
+LINUX_VERSION-3.18 = .10
 LINUX_VERSION-4.0 = -rc5
 
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
 LINUX_KERNEL_MD5SUM-3.14.35 = e5e92c40d14bc8ae9a8701db4e1cbb27
-LINUX_KERNEL_MD5SUM-3.18.9  = 44cd16ada5eb03589f696f083cd2323b
+LINUX_KERNEL_MD5SUM-3.18.10 = 1e8ad8a122e332e429d4c786ece4582e
 LINUX_KERNEL_MD5SUM-4.0-rc5 = b26150c980099ef554b26d07f470e647
 
 ifdef KERNEL_PATCHVER
index e8b21e50607d9ecb16a6207405071396746913a6..3f0dcd3ae27fe42f548e8968ad17697d0fc40f78 100644 (file)
@@ -52,7 +52,7 @@
  
  int __ipv6_get_lladdr(struct inet6_dev *idev, struct in6_addr *addr,
                      u32 banned_flags)
-@@ -5434,6 +5433,9 @@ int __init addrconf_init(void)
+@@ -5451,6 +5450,9 @@ int __init addrconf_init(void)
  
        ipv6_addr_label_rtnl_register();
  
@@ -62,7 +62,7 @@
        return 0;
  errout:
        rtnl_af_unregister(&inet6_ops);
-@@ -5453,6 +5455,9 @@ void addrconf_cleanup(void)
+@@ -5470,6 +5472,9 @@ void addrconf_cleanup(void)
        struct net_device *dev;
        int i;
  
index 6da486bb27318a3051ffece8e7379a261c1fd4c0..5c63dbec62ae69e46db81486c6b1589be9ab6c8d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/phy.c
 +++ b/drivers/net/phy/phy.c
-@@ -338,6 +338,50 @@ int phy_ethtool_gset(struct phy_device *
+@@ -357,6 +357,50 @@ int phy_ethtool_gset(struct phy_device *
  }
  EXPORT_SYMBOL(phy_ethtool_gset);
  
diff --git a/target/linux/mvebu/patches-3.18/210-xhci_move_marvell_quirks.patch b/target/linux/mvebu/patches-3.18/210-xhci_move_marvell_quirks.patch
deleted file mode 100644 (file)
index 2296900..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-From 1e7e4fb66489cc84366656ca5318f1cb61afd4ba Mon Sep 17 00:00:00 2001
-From: Maxime Ripard <maxime.ripard@free-electrons.com>
-Date: Tue, 24 Feb 2015 18:27:00 +0200
-Subject: usb: XHCI: platform: Move the Marvell quirks after the enabling the
- clocks
-
-The commit 973747928514 ("usb: host: xhci-plat: add support for the Armada
-375/38x XHCI controllers") extended the xhci-plat driver to support the Armada
-375/38x SoCs, mostly by adding a quirk configuring the MBUS window.
-
-However, that quirk was run before the clock the controllers needs has been
-enabled. This usually worked because the clock was first enabled by the
-bootloader, and left as such until the driver is probe, where it tries to
-access the MBUS configuration registers before enabling the clock.
-
-Things get messy when EPROBE_DEFER is involved during the probe, since as part
-of its error path, the driver will rightfully disable the clock. When the
-driver will be reprobed, it will retry to access the MBUS registers, but this
-time with the clock disabled, which hangs forever.
-
-Fix this by running the quirks after the clock has been enabled by the driver.
-
-Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
-Cc: <stable@vger.kernel.org> # v3.16+
-Signed-off-by: Mathias Nyman <mathias.nyman@linux.intel.com>
-Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
-
---- a/drivers/usb/host/xhci-plat.c
-+++ b/drivers/usb/host/xhci-plat.c
-@@ -87,15 +87,6 @@ static int xhci_plat_probe(struct platfo
-       if (!res)
-               return -ENODEV;
--      if (of_device_is_compatible(pdev->dev.of_node,
--                                  "marvell,armada-375-xhci") ||
--          of_device_is_compatible(pdev->dev.of_node,
--                                  "marvell,armada-380-xhci")) {
--              ret = xhci_mvebu_mbus_init_quirk(pdev);
--              if (ret)
--                      return ret;
--      }
--
-       /* Initialize dma_mask and coherent_dma_mask to 32-bits */
-       ret = dma_set_coherent_mask(&pdev->dev, DMA_BIT_MASK(32));
-       if (ret)
-@@ -129,6 +120,15 @@ static int xhci_plat_probe(struct platfo
-                       goto put_hcd;
-       }
-+      if (of_device_is_compatible(pdev->dev.of_node,
-+                                  "marvell,armada-375-xhci") ||
-+          of_device_is_compatible(pdev->dev.of_node,
-+                                  "marvell,armada-380-xhci")) {
-+              ret = xhci_mvebu_mbus_init_quirk(pdev);
-+              if (ret)
-+                      return ret;
-+      }
-+
-       ret = usb_add_hcd(hcd, irq, IRQF_SHARED);
-       if (ret)
-               goto disable_clk;