Add sox #816
authorFlorian Fainelli <florian@openwrt.org>
Thu, 2 Nov 2006 22:09:39 +0000 (22:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 2 Nov 2006 22:09:39 +0000 (22:09 +0000)
SVN-Revision: 5382

sound/sox/Makefile [new file with mode: 0644]
sound/sox/patches/01-math_functions.patch [new file with mode: 0644]

diff --git a/sound/sox/Makefile b/sound/sox/Makefile
new file mode 100644 (file)
index 0000000..bab312b
--- /dev/null
@@ -0,0 +1,57 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 5329 2006-10-28 22:43:08Z nico $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sox
+PKG_VERSION:=12.18.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/sox
+PKG_MD5SUM:=ba25e512a6c824d6e56d76767a18af99
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/sox
+  SECTION:=sound
+  CATEGORY:=Sound
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libnotimpl
+  TITLE:=Sox is a general purpose sound converter/player/recorder
+  DESCRIPTION:=\
+       SoX is a command line utility that can convert various formats\\\
+       of computer audio files in to other formats. It can also apply\\\
+       various effects to these sound files during the conversion.\\\
+       As an added bonus, SoX can play and record audio files on\\\
+       several unix-style platforms.
+  URL:=http://sox.sourceforge.net/
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --disable-external-gsm \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               STAGING_DIR="$(STAGING_DIR)" \
+               all
+endef
+
+define Package/sox/install
+       install -d -m0755 $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/src/{play,sox,soxmix} $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,sox))
diff --git a/sound/sox/patches/01-math_functions.patch b/sound/sox/patches/01-math_functions.patch
new file mode 100644 (file)
index 0000000..237a2be
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN sox-12.18.2/src/Makefile.in sox-12.18.2.new/src/Makefile.in
+--- sox-12.18.2/src/Makefile.in        2006-08-28 01:04:51.000000000 +0200
++++ sox-12.18.2.new/src/Makefile.in    2006-11-02 22:57:54.000000000 +0100
+@@ -29,7 +29,7 @@
+ CFLAGS        = @CFLAGS@ -I$(srcdir) -I$(builddir)
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS       = -L. @LDFLAGS@
+-LIBS  = -lst @LIBS@
++LIBS  = -lst @LIBS@ -lnotimpl
+ # Other macros.