firewall3: move libext*.a copying to compile phase
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 21 May 2013 12:58:36 +0000 (12:58 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 21 May 2013 12:58:36 +0000 (12:58 +0000)
SVN-Revision: 36684

package/network/config/firewall3/Makefile

index 1ab4eaa4721aa2a7905a2c121c97ccc73e27d3f1..5ddc792d1d578d8a835a5fc458147c434e1d91ee 100644 (file)
@@ -39,11 +39,11 @@ define Package/firewall3/conffiles
 /etc/firewall.user
 endef
 
-define Build/Prepare
-       $(call Build/Prepare/Default)
+define Build/Compile
        $(CP) $(lastword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/extensions/libext.a)) $(PKG_BUILD_DIR)/libext.a
        $(CP) $(lastword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/extensions/libext4.a)) $(PKG_BUILD_DIR)/libext4.a
        $(CP) $(lastword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/extensions/libext6.a)) $(PKG_BUILD_DIR)/libext6.a
+       $(call Build/Compile/Default)
 endef
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections