allow the kernel to provide own series files for specific subdirs
authorFelix Fietkau <nbd@openwrt.org>
Thu, 30 Aug 2007 21:11:17 +0000 (21:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 30 Aug 2007 21:11:17 +0000 (21:11 +0000)
SVN-Revision: 8557

include/quilt.mk

index dc5a9d2b698e002b0a26020bd669f300c2d3a4b2..3a6f0dc754ea78fa68d596ae1b5e2f77a5b9579b 100644 (file)
@@ -59,6 +59,25 @@ define Kernel/Patch/Default
        $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
+ifeq ($(KERNEL_BUILD),1)
+$(STAMP_PATCHED): $(STAMP_PREPARED)
+       @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
+       (\
+               cd $(PKG_BUILD_DIR)/patches; \
+               rm -f series; \
+               for file in *; do \
+                       if [ -f $$file/series ]; then \
+                               echo "Converting $$file/series"; \
+                               awk -v file="$$file/" '$$0 !~ /^#/ { print file $$0 }' $$file/series >> series; \
+                       else \
+                               echo "Sorting patches in $$file"; \
+                               find $$file/* -type f \! -name series | sort >> series; \
+                       fi; \
+               done; \
+       )
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
+       touch $@
+else
 $(STAMP_PATCHED): $(STAMP_PREPARED)
        @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
        (\
@@ -67,6 +86,7 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
        )
        if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
        touch $@
+endif
 
 define Quilt/RefreshDir
        mkdir -p $(1)