[package] base-files: respect .auto option when running coldplug_interface_*() hooks...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 27 May 2010 23:04:56 +0000 (23:04 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 27 May 2010 23:04:56 +0000 (23:04 +0000)
SVN-Revision: 21588

package/base-files/Makefile
package/base-files/files/etc/init.d/network

index 1a92a59d9d5b0f17db139a73d6b2864412fc8537..9eab5e544e8e5604163fa76aa8b8cf3318c67c0e 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=44
+PKG_RELEASE:=45
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index d60d41a64e07726011ff529b2bb71a9294465534..9d4904ae4301d14f1dcc38b3bcf5011914c2d560 100755 (executable)
@@ -23,7 +23,10 @@ boot() {
                local proto
                config_get proto "$ifc" proto
 
-               type "coldplug_interface_$proto" >/dev/null && \
+               local auto
+               config_get_bool auto "$ifc" auto 1
+
+               type "coldplug_interface_$proto" >/dev/null && [ "$auto" = 1 ] && \
                        coldplug_interface_$proto "$ifc"
        done
 }