[packages] dsl-qos-queue: use shared libipq (#8355)
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Dec 2010 21:40:05 +0000 (21:40 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Dec 2010 21:40:05 +0000 (21:40 +0000)
SVN-Revision: 24249

net/dsl-qos-queue/Makefile

index 99a2d3e98e5c8a4ed8de72440a6687ee9bc3b1b4..174ef14b31ab5535857d5cf37bd55b1161986984 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dsl_qos_queue
 PKG_VERSION:=0.9.3
 
 PKG_NAME:=dsl_qos_queue
 PKG_VERSION:=0.9.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sonicspike.net/software/download/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sonicspike.net/software/download/
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables +kmod-ipt-queue +iptables-mod-ipopt @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
+  DEPENDS:=+iptables +kmod-ipt-queue +iptables-mod-ipopt +libipq @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
   TITLE:=ADSL/ATM Bandwith management
   URL:=http://www.sonicspike.net/software/
 endef
   TITLE:=ADSL/ATM Bandwith management
   URL:=http://www.sonicspike.net/software/
 endef
@@ -34,7 +34,7 @@ define Build/Compile
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               LIBIPQ=$(STAGING_DIR)/usr/lib/libipq.a \
+               LIBIPQ="-lipq" \
                all \
        )
 endef
                all \
        )
 endef