[packages] dovecot: update to 1.2.10
authorStephen Walker <stephendwalker@gmail.com>
Fri, 29 Jan 2010 16:07:09 +0000 (16:07 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Fri, 29 Jan 2010 16:07:09 +0000 (16:07 +0000)
SVN-Revision: 19381

mail/dovecot/Makefile

index 0e562f02a942f9188dac6bd01514c2af51848de7..79216d2b57b47ece6622f795fd056a82f59c2445 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dovecot
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dovecot
-PKG_VERSION:=1.2.9
+PKG_VERSION:=1.2.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.2
-PKG_MD5SUM:=036ff97fb248dae3bd4b796a0644634f
+PKG_MD5SUM:=b7d0081b17ff6afae85e8dc14157fa57
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,34 +31,30 @@ define Package/dovecot/description
  Dovecot is a program which provides POP3 and IMAP services.
 endef
 
  Dovecot is a program which provides POP3 and IMAP services.
 endef
 
+CONFIGURE_ARGS += \
+       --without-gssapi \
+       --without-pam \
+       --with-moduledir=/usr/lib/dovecot/modules \
+       --with-notify=dnotify \
+
+CONFIGURE_VARS += \
+       RPCGEN= \
+       i_cv_signed_size_t=no \
+       i_cv_signed_time_t=no \
+       i_cv_gmtime_max_time_t=32 \
+       i_cv_mmap_plays_with_write=yes \
+       i_cv_fd_passing=yes \
+       i_cv_c99_vsnprintf=yes \
+       lib_cv_va_copy=yes \
+       lib_cv_va_copy=yes \
+       lib_cv___va_copy=yes \
+       lib_cv_va_val_copy=yes \
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
                autoconf \
        );
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
                autoconf \
        );
-       $(call Build/Configure/Default, \
-               --without-gssapi \
-               --without-pam \
-               --with-moduledir=/usr/lib/dovecot/modules \
-               --with-notify=dnotify \
-               , \
-               RPCGEN= \
-               i_cv_signed_size_t=no \
-               i_cv_signed_time_t=no \
-               i_cv_gmtime_max_time_t=32 \
-               i_cv_mmap_plays_with_write=yes \
-               i_cv_fd_passing=yes \
-               i_cv_c99_vsnprintf=yes \
-               lib_cv_va_copy=yes \
-               lib_cv_va_copy=yes \
-               lib_cv___va_copy=yes \
-               lib_cv_va_val_copy=yes \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(call Build/Configure/Default)
 endef
 
 define Package/dovecot/install
 endef
 
 define Package/dovecot/install