[8.09] x86: merge r13158
authorNicolas Thill <nico@openwrt.org>
Mon, 28 Sep 2009 11:22:09 +0000 (11:22 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 28 Sep 2009 11:22:09 +0000 (11:22 +0000)
SVN-Revision: 17780

target/linux/x86/Makefile
target/linux/x86/image/Config.in
target/linux/x86/image/Makefile

index 566ec275b484dc1c7c3b721d9d55e8accb990985..85d70484f1107db5c4337d5ddd68ec6e1500c125 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi
+FEATURES:=squashfs jffs2 ext2 vdi vmdk
 SUBTARGETS=generic
 
 LINUX_VERSION:=2.6.25.20
index 5706e4464015eb29fc24ea7752447b231502a1aa..ef7d0cd855b6d2bf5c8bc01c422756b8844c23fd 100644 (file)
@@ -42,4 +42,9 @@ config X86_VDI_IMAGES
     depends X86_GRUB_IMAGES
     select PACKAGE_kmod-pcnet32
 
-
+config X86_VMDK_IMAGES
+    bool "Build VMware image files (VMDK). Requires qemu-img"
+    depends TARGET_x86
+    depends TARGET_ROOTFS_EXT2FS
+    depends X86_GRUB_IMAGES
+    select PACKAGE_kmod-e1000
index 9980cf01524ef4ba585e71b26b8f2419902ba280..839646e547e96231916f754439cb631f0d5d7fa8 100644 (file)
@@ -71,6 +71,16 @@ ifeq ($(CONFIG_X86_VDI_IMAGES),y)
   endef
 endif
 
+ifeq ($(CONFIG_X86_VMDK_IMAGES),y)
+  define Image/Build/vmdk
+    # left here because the image builder doesnt need these
+    ifeq ($(1),ext2)
+               rm $(BIN_DIR)/openwrt-$(BOARD)-ext2.vmdk || true
+               qemu-img convert -f raw $(BIN_DIR)/openwrt-$(BOARD)-ext2.image \
+                       -O vmdk $(BIN_DIR)/openwrt-$(BOARD)-ext2.vmdk
+    endif
+  endef
+endif
 
 define Image/Prepare
        $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
@@ -103,6 +113,7 @@ define Image/Build
        $(call Image/Build/$(1))
        $(call Image/Build/grub,$(1))
        $(call Image/Build/vdi,$(1))
+       $(call Image/Build/vmdk,$(1))
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
 endef
@@ -115,3 +126,8 @@ ifeq ($(CONFIG_X86_VDI_IMAGES),y)
   ))
 endif
 
+ifeq ($(CONFIG_X86_VMDK_IMAGES),y)
+   $(eval $(call RequireCommand,qemu-img, \
+       You need qemu-img to generate VMware images. \
+   ))
+endif