Add nbd client package from #2266
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Nov 2008 17:24:48 +0000 (17:24 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Nov 2008 17:24:48 +0000 (17:24 +0000)
SVN-Revision: 13155

net/nbd/Makefile [new file with mode: 0644]
net/nbd/patches/configure [new file with mode: 0644]

diff --git a/net/nbd/Makefile b/net/nbd/Makefile
new file mode 100644 (file)
index 0000000..c7d7034
--- /dev/null
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $ 
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nbd
+PKG_VERSION:=2.9.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/nbd
+PKG_MD5SUM:=7fdd912edba85b82f599e17449ccea40
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_BUILD_DEPENDS:=glib2 libintl
+
+define Package/nbd
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Network Block Device utilities
+  URL:=http://nbd.sourceforge.net
+endef
+
+define Package/nbd/description
+  This package contains the network block device client.
+endef
+
+CONFIGURE_ARGS += \
+       --disable-glibtest
+CONFIGURE_VARS += GLIB_CFLAGS="-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include"
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS) -L$(STAGING_DIR)/usr/lib/libintl/lib/ -L$(STAGING_DIR)/usr/lib/" \
+               nbd-client
+endef
+
+define Package/nbd/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nbd-client $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,nbd))
diff --git a/net/nbd/patches/configure b/net/nbd/patches/configure
new file mode 100644 (file)
index 0000000..ba36929
--- /dev/null
@@ -0,0 +1,13 @@
+diff -ruN nbd-2.9.6-orig/configure nbd-2.9.6/configure
+--- nbd-2.9.6-orig/configure   2007-07-19 11:43:57.000000000 +0200
++++ nbd-2.9.6/configure        2007-08-14 14:07:15.181535264 +0200
+@@ -8076,7 +8076,8 @@
+      GLIB_MKENUMS=""
+      { { echo "$as_me:$LINENO: error: Missing glib" >&5
+ echo "$as_me: error: Missing glib" >&2;}
+-   { (exit 1); exit 1; }; }
++#   { (exit 1); exit 1; }; }
++}
+   fi