tools: add tool to generate dcs93xl images
authorJohn Crispin <john@openwrt.org>
Mon, 7 Oct 2013 15:01:05 +0000 (15:01 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 7 Oct 2013 15:01:05 +0000 (15:01 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 38317

tools/firmware-utils/Makefile
tools/firmware-utils/src/mkdcs932.c [new file with mode: 0644]

index 45690f5949e982bfaa1a5a173f0582d4a9d0d021..770fcf5fd4637553ec3d5da3ec86edc2b6cd7c8d 100644 (file)
@@ -65,6 +65,7 @@ define Host/Compile
        $(call cc,fix-u-media-header cyg_crc32,-Wall)
        $(call cc,hcsmakeimage bcmalgo)
        $(call cc,mkporayfw, -Wall)
+       $(call cc,mkdcs932, -Wall)
 endef
 
 define Host/Install
diff --git a/tools/firmware-utils/src/mkdcs932.c b/tools/firmware-utils/src/mkdcs932.c
new file mode 100644 (file)
index 0000000..28c67aa
--- /dev/null
@@ -0,0 +1,39 @@
+/*
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License,
+ * version 2 as published by the Free Software Foundation.
+ *
+ * (C) John Crispin <blogic@openwrt.org>
+ */
+
+#include <sys/types.h>
+#include <sys/stat.h>
+#include <fcntl.h>
+#include <stdio.h>
+#include <stdint.h>
+#include <unistd.h>
+#include <errno.h>
+
+int main(int argc, char **argv)
+{
+       uint32_t t = 0, sum = 0x55aa55aa;
+       int fd;
+
+       if ((argc != 2) || ((fd = open(argv[1], O_RDWR)) == -1)) {
+               fprintf(stderr, "Usage: %s input_file\n", *argv);
+               return -EINVAL;
+       }
+
+       lseek(fd, -4, SEEK_END);
+       write(fd, &t, 4);
+       lseek(fd, 0, SEEK_SET);
+
+       while (read(fd, &t, 4) > 0)
+               sum -= t;
+
+       lseek(fd, -4, SEEK_END);
+       write(fd, &sum, 4);
+       close(fd);
+
+       return 0;
+}