[package] busybox: disable busybox' own stripping, fixes stripped bb binary in STAGIN...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 25 Feb 2010 00:42:09 +0000 (00:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 25 Feb 2010 00:42:09 +0000 (00:42 +0000)
SVN-Revision: 19852

package/busybox/Makefile

index 43da0a48deb7e22c26052734ceadcec517925ac8..c5380611983ae0bd6cb11d614e763b74e900d240 100644 (file)
@@ -70,6 +70,7 @@ define Build/Compile
                KBUILD_HAVE_NLS=no \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
                ARCH="$(ARCH)" \
+               SKIP_STIP=y \
                all
        rm -rf $(PKG_INSTALL_DIR)
        $(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
@@ -78,7 +79,6 @@ define Build/Compile
                CROSS_COMPILE="$(TARGET_CROSS)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
                ARCH="$(ARCH)" \
-               IPKG_ARCH="$(ARCH)" \
                CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
                install
 endef