add miax package (thanks to Markus Becker)
authorNicolas Thill <nico@openwrt.org>
Wed, 30 Nov 2005 00:59:59 +0000 (00:59 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 30 Nov 2005 00:59:59 +0000 (00:59 +0000)
SVN-Revision: 2570

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/miax/Config.in [new file with mode: 0644]
openwrt/package/miax/Makefile [new file with mode: 0644]
openwrt/package/miax/ipkg/miax.control [new file with mode: 0644]
openwrt/package/miax/patches/01-cross.patch [new file with mode: 0644]

index 64db11355e1f4d00c7bfdb15f7898d4952f12ab2..24003434c093a5976a3c42d5ae7c8dd6742360c5 100644 (file)
@@ -236,6 +236,7 @@ source "package/util-linux/Config.in"
 comment "Bluetooth"
 source "package/bluez-libs/Config.in"
 source "package/bluez-utils/Config.in"
+source "package/miax/Config.in"
 
 comment "Extra stuff"
 source "package/sdk/Config.in"
index e5f161db5d90d21e78d8e0b90c99561431b08ee0..a087a9363792c1c391ddc454591dc1ad06468700 100644 (file)
@@ -108,6 +108,7 @@ package-$(BR2_COMPILE_LUA) += lua
 package-$(BR2_PACKAGE_MADWIFI_TOOLS) += madwifi-tools
 package-$(BR2_PACKAGE_MARADNS) += maradns
 package-$(BR2_COMPILE_MATRIXSSL) += matrixssl
+package-$(BR2_PACKAGE_MIAX) += miax
 package-$(BR2_PACKAGE_MICROCOM) += microcom
 package-$(BR2_PACKAGE_MICROPERL) += microperl
 package-$(BR2_COMPILE_MINI_HTTPD) += mini_httpd
@@ -263,6 +264,7 @@ libvorbis-compile: libogg-compile
 libxml2-compile: zlib-compile
 libxslt-compile: libxml2-compile
 lighttpd-compile: openssl-compile pcre-compile
+miax-compile: bluez-libs-compile
 miredo-compile: uclibc++-compile
 mt-daapd-compile: howl-compile libgdbm-compile libid3tag-compile
 mtr-compile: ncurses-compile
diff --git a/openwrt/package/miax/Config.in b/openwrt/package/miax/Config.in
new file mode 100644 (file)
index 0000000..9cd66b1
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_MIAX
+       prompt "miax.............................. A console iax (asterisk) client"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_BLUEZ_LIBS
+       select BR2_PACKAGE_LIBPTHREAD
+       help
+         miax is a console iax (asterisk) client, it can work with
+         a soundcard as a normal voip phone, taking input/output from
+         keyboard, analog/gsm/isdn modem or bluetooth phones.
+         
+         http://www.eja.it/?l=gpl&testo=miax
diff --git a/openwrt/package/miax/Makefile b/openwrt/package/miax/Makefile
new file mode 100644 (file)
index 0000000..e121f8d
--- /dev/null
@@ -0,0 +1,36 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=miax
+PKG_VERSION:=1.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=44f0d2ef46ee2697d890b7b96846adc7
+
+PKG_SOURCE_URL:=http://mesh.dl.sourceforge.net/sourceforge/miax/
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MIAX,miax,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C "$(PKG_BUILD_DIR)" \
+               CC="$(TARGET_CC)" \
+               OFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               all
+       touch $@
+
+$(IPKG_MIAX):
+       install -d -m0755 $(IDIR_MIAX)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/miax $(IDIR_MIAX)/usr/bin/
+       $(RSTRIP) $(IDIR_MIAX)
+       $(IPKG_BUILD) $(IDIR_MIAX) $(PACKAGE_DIR)
diff --git a/openwrt/package/miax/ipkg/miax.control b/openwrt/package/miax/ipkg/miax.control
new file mode 100644 (file)
index 0000000..78e47f5
--- /dev/null
@@ -0,0 +1,5 @@
+Package: miax
+Priority: optional
+Section: net
+Description: A console iax (asterisk) client
+Depends: kmod-bluetooth, bluez-libs, libpthread
diff --git a/openwrt/package/miax/patches/01-cross.patch b/openwrt/package/miax/patches/01-cross.patch
new file mode 100644 (file)
index 0000000..f47c110
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN miax-1.4-old/Makefile miax-1.4-new/Makefile
+--- miax-1.4-old/Makefile      2005-04-27 18:56:13.000000000 +0200
++++ miax-1.4-new/Makefile      2005-11-30 01:07:21.000000000 +0100
+@@ -1,4 +1,5 @@
+-CFLAGS= -Iiax/ -Igsm/inc -DIAXC_IAX2 -DLIBIAX -g -DPOSIXSLEEP -DLINUX -O2 
++OFLAGS= -02 -g
++CFLAGS= -Iiax/ -Igsm/inc $(CPPFLAGS) -DIAXC_IAX2 -DLIBIAX -DPOSIXSLEEP -DLINUX $(OFLAGS)
+ SYSLIBS=-lpthread -lm -lbluetooth
+@@ -32,11 +33,10 @@
+       miax.o
+ all: $(OBJS)
+-      gcc $(OBJS) $(CFLAGS) $(SYSLIBS)  -o miax
+-      cp miax /bin/miax
++      $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) $(SYSLIBS) -o miax
+ static: $(OBJS) bluetooth.o 
+-      gcc $(OBJS) $(CFLAGS) $(SYSLIBS)  -static -o miax
++      $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) $(SYSLIBS) -static -o miax
+ clean: 
+       rm -f $(OBJS) miax