[adm5120] remove dashes from profile names
authorGabor Juhos <juhosg@openwrt.org>
Fri, 5 Oct 2007 08:29:58 +0000 (08:29 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 5 Oct 2007 08:29:58 +0000 (08:29 +0000)
SVN-Revision: 9132

target/linux/adm5120/image/router_be.mk
target/linux/adm5120/image/router_le.mk
target/linux/adm5120/router_be/profiles/200-ZyXEL.mk
target/linux/adm5120/router_le/profiles/Cellvision.mk

index c45d281695a9ff4d82cf9b3d7a405c581e1bef5a..05f4b0073243d733134134820e39e82c61e1cddd 100644 (file)
@@ -12,38 +12,38 @@ endef
 #
 # ZyXEL Prestige 334WT
 #
 #
 # ZyXEL Prestige 334WT
 #
-define Image/Build/Board/P-334WT
+define Image/Build/Board/P334WT
        $(call Image/Build/ZyXEL,$(1),p-334wt)
 endef
 
        $(call Image/Build/ZyXEL,$(1),p-334wt)
 endef
 
-define Image/Build/Board/P-334WT/squashfs
-       $(call Image/Build/Board/P-334WT,squashfs)
+define Image/Build/Board/P334WT/squashfs
+       $(call Image/Build/Board/P334WT,squashfs)
 endef
 
 endef
 
-define Image/Build/Board/P-334WT/jffs2-64k
-       $(call Image/Build/Board/P-334WT,jffs2-64k)
+define Image/Build/Board/P334WT/jffs2-64k
+       $(call Image/Build/Board/P334WT,jffs2-64k)
 endef
 
 endef
 
-define Image/Build/Board/P-334WT/Initramfs
+define Image/Build/Board/P334WT/Initramfs
        $(call Image/Build/LZMAKernel/KArgs,p-334wt,bin)
 endef
 
 #
 # ZyXEL Prestige 335WT
 #
        $(call Image/Build/LZMAKernel/KArgs,p-334wt,bin)
 endef
 
 #
 # ZyXEL Prestige 335WT
 #
-define Image/Build/Board/P-335WT
+define Image/Build/Board/P335WT
        $(call Image/Build/ZyXEL,$(1),p-335wt)
 endef
 
        $(call Image/Build/ZyXEL,$(1),p-335wt)
 endef
 
-define Image/Build/Board/P-335WT/squashfs
-       $(call Image/Build/Board/P-335WT,$(1))
+define Image/Build/Board/P335WT/squashfs
+       $(call Image/Build/Board/P335WT,$(1))
 endef
 
 endef
 
-define Image/Build/Board/P-335WT/jffs2-64k
-       $(call Image/Build/Board/P-335WT,$(1))
+define Image/Build/Board/P335WT/jffs2-64k
+       $(call Image/Build/Board/P335WT,$(1))
 endef
 
 endef
 
-define Image/Build/Board/P-335WT/Initramfs
+define Image/Build/Board/P335WT/Initramfs
        $(call Image/Build/LZMAKernel/KArgs,p-335wt,bin)
 endef
 
        $(call Image/Build/LZMAKernel/KArgs,p-335wt,bin)
 endef
 
@@ -51,8 +51,8 @@ endef
 # Groups
 #
 define Image/Build/Group/All
 # Groups
 #
 define Image/Build/Group/All
-       $(call Image/Build/Board/P-334WT/$(1))
-       $(call Image/Build/Board/P-335WT/$(1))
+       $(call Image/Build/Board/P334WT/$(1))
+       $(call Image/Build/Board/P335WT/$(1))
 endef
 
 #
 endef
 
 #
@@ -70,10 +70,10 @@ define Image/Build/Profile/Texas
        $(call Image/Build/Group/All,$(1))
 endef
 
        $(call Image/Build/Group/All,$(1))
 endef
 
-define Image/Build/Profile/P-334WT
-       $(call Image/Build/Board/P-334WT/$(1))
+define Image/Build/Profile/P334WT
+       $(call Image/Build/Board/P334WT/$(1))
 endef
 
 endef
 
-define Image/Build/Profile/P-335WT
-       $(call Image/Build/Board/P-335WT/$(1))
+define Image/Build/Profile/P335WT
+       $(call Image/Build/Board/P335WT/$(1))
 endef
 endef
index be70ed21a50cf17d9a0a995b7112db816fdf25d1..9f1aa9b2bee1a94c341dc20a6f39027323ec304e 100644 (file)
@@ -40,14 +40,14 @@ endef
 #
 # Cellvision CAS-771
 #
 #
 # Cellvision CAS-771
 #
-define Image/Build/Board/CAS-771/Initramfs
+define Image/Build/Board/CAS771/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,cas-771,gz)
 endef
 
 #
 # Cellvision CAS-771W
 #
        $(call Image/Build/LZMAKernel/Admboot,cas-771,gz)
 endef
 
 #
 # Cellvision CAS-771W
 #
-define Image/Build/Board/CAS-771W/Initramfs
+define Image/Build/Board/CAS771W/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,cas-771w,gz)
 endef
 
        $(call Image/Build/LZMAKernel/Admboot,cas-771w,gz)
 endef
 
@@ -168,57 +168,57 @@ endef
 #
 # Compex WP54G-WRT
 #
 #
 # Compex WP54G-WRT
 #
-define Image/Build/Board/WP54G-WRT
+define Image/Build/Board/WP54GWRT
        $(call Image/Build/Compex,$(1),wp54g-wrt)
 endef
 
        $(call Image/Build/Compex,$(1),wp54g-wrt)
 endef
 
-define Image/Build/Board/WP54G-WRT/squashfs
-       $(call Image/Build/Board/WP54G-WRT,squashfs)
+define Image/Build/Board/WP54GWRT/squashfs
+       $(call Image/Build/Board/WP54GWRT,squashfs)
 endef
 
 endef
 
-define Image/Build/Board/WP54G-WRT/jffs2-64k
-       $(call Image/Build/Board/WP54G-WRT,jffs2-64k)
+define Image/Build/Board/WP54GWRT/jffs2-64k
+       $(call Image/Build/Board/WP54GWRT,jffs2-64k)
 endef
 
 endef
 
-define Image/Build/Board/WP54G-WRT/Initramfs
+define Image/Build/Board/WP54GWRT/Initramfs
        $(call Image/Build/LZMAKernel/KArgs,wp54g-wrt,bin)
 endef
 
 #
 # Edimax BR-6104K/KP
 #
        $(call Image/Build/LZMAKernel/KArgs,wp54g-wrt,bin)
 endef
 
 #
 # Edimax BR-6104K/KP
 #
-define Image/Build/Board/BR-6104K
+define Image/Build/Board/BR6104K
        $(call Image/Build/Edimax,$(1),br-6104k)
 endef
 
        $(call Image/Build/Edimax,$(1),br-6104k)
 endef
 
-define Image/Build/Board/BR-6104K/squashfs
-       $(call Image/Build/Board/BR-6104K,squashfs)
+define Image/Build/Board/BR6104K/squashfs
+       $(call Image/Build/Board/BR6104K,squashfs)
 endef
 
 endef
 
-define Image/Build/Board/BR-6104K/jffs2-64k
-       $(call Image/Build/Board/BR-6104K,jffs2-64k)
+define Image/Build/Board/BR6104K/jffs2-64k
+       $(call Image/Build/Board/BR6104K,jffs2-64k)
 endef
 
 endef
 
-define Image/Build/Board/BR-6104K/Initramfs
+define Image/Build/Board/BR6104K/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
 endef
 
 #
 # Infineon EASY 83000
 #
        $(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
 endef
 
 #
 # Infineon EASY 83000
 #
-define Image/Build/Board/EASY-83000
+define Image/Build/Board/EASY83000
        $(call Image/Build/Infineon,$(1),easy-83000)
 endef
 
        $(call Image/Build/Infineon,$(1),easy-83000)
 endef
 
-define Image/Build/Board/EASY-83000/squashfs
-       $(call Image/Build/Board/EASY-83000,squashfs)
+define Image/Build/Board/EASY83000/squashfs
+       $(call Image/Build/Board/EASY83000,squashfs)
 endef
 
 endef
 
-define Image/Build/Board/EASY-83000/jffs2-64k
-       $(call Image/Build/Board/EASY-83000,jffs2-64k)
+define Image/Build/Board/EASY83000/jffs2-64k
+       $(call Image/Build/Board/EASY83000,jffs2-64k)
 endef
 
 endef
 
-define Image/Build/Board/EASY-83000/Initramfs
+define Image/Build/Board/EASY83000/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,easy-83000,gz)
 endef
 
        $(call Image/Build/LZMAKernel/Admboot,easy-83000,gz)
 endef
 
@@ -233,8 +233,8 @@ endef
 # Groups
 #
 define Image/Build/Group/Cellvision
 # Groups
 #
 define Image/Build/Group/Cellvision
-       $(call Image/Build/Board/CAS-771/$(1))
-       $(call Image/Build/Board/CAS-771W/$(1))
+       $(call Image/Build/Board/CAS771/$(1))
+       $(call Image/Build/Board/CAS771W/$(1))
 endef
 
 define Image/Build/Group/WP54G
 endef
 
 define Image/Build/Group/WP54G
@@ -242,7 +242,7 @@ define Image/Build/Group/WP54G
        $(call Image/Build/Board/WP54AG/$(1))
        $(call Image/Build/Board/WPP54G/$(1))
        $(call Image/Build/Board/WPP54AG/$(1))
        $(call Image/Build/Board/WP54AG/$(1))
        $(call Image/Build/Board/WPP54G/$(1))
        $(call Image/Build/Board/WPP54AG/$(1))
-       $(call Image/Build/Board/WP54G-WRT/$(1))
+       $(call Image/Build/Board/WP54GWRT/$(1))
 endef
 
 define Image/Build/Group/Compex
 endef
 
 define Image/Build/Group/Compex
@@ -253,11 +253,11 @@ define Image/Build/Group/Compex
 endef
 
 define Image/Build/Group/Edimax
 endef
 
 define Image/Build/Group/Edimax
-       $(call Image/Build/Board/BR-6104K/$(1))
+       $(call Image/Build/Board/BR6104K/$(1))
 endef
 
 define Image/Build/Group/Infineon
 endef
 
 define Image/Build/Group/Infineon
-       $(call Image/Build/Board/EASY-83000/$(1))
+       $(call Image/Build/Board/EASY83000/$(1))
 endef
 
 define Image/Build/Group/All
 endef
 
 define Image/Build/Group/All
@@ -300,12 +300,12 @@ define Image/Build/Profile/NP28G
        $(call Image/Build/Board/NP28G/$(1))
 endef
 
        $(call Image/Build/Board/NP28G/$(1))
 endef
 
-define Image/Build/Profile/CAS-771
-       $(call Image/Build/Board/CAS-771/$(1))
+define Image/Build/Profile/CAS771
+       $(call Image/Build/Board/CAS771/$(1))
 endef
 
 endef
 
-define Image/Build/Profile/CAS-771W
-       $(call Image/Build/Board/CAS-771W/$(1))
+define Image/Build/Profile/CAS771W
+       $(call Image/Build/Board/CAS771W/$(1))
 endef
 
 define Image/Build/Profile/RouterBoard
 endef
 
 define Image/Build/Profile/RouterBoard
index 0af5613a3871d16ceab6757ab701e9a58857c70f..4ce8ecadf7d9f7f4070b328eadf56e5652693f16 100644 (file)
@@ -5,23 +5,23 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
-define Profile/P-334WT
-       NAME:=ZyXEL Prestige P-334WT
+define Profile/P334WT
+       NAME:=ZyXEL Prestige 334WT
        PACKAGES:=kmod-acx
 endef
 
        PACKAGES:=kmod-acx
 endef
 
-define Profile/P-334WT/Description
-       Package set optimized for the ZyXEL Prestige P-334WT board.
+define Profile/P334WT/Description
+       Package set optimized for the ZyXEL Prestige 334WT board.
 endef
 
 endef
 
-define Profile/P-335WT
-       NAME:=ZyXEL Prestige P-335WT
+define Profile/P335WT
+       NAME:=ZyXEL Prestige 335WT
        PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
 endef
 
        PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
 endef
 
-define Profile/P-335WT/Description
-       Package set optimized for the ZyXEL Prestige P-335WT board.
+define Profile/P335WT/Description
+       Package set optimized for the ZyXEL Prestige 335WT board.
 endef
 
 endef
 
-$(eval $(call Profile,P-334WT))
-$(eval $(call Profile,P-335WT))
+$(eval $(call Profile,P334WT))
+$(eval $(call Profile,P335WT))
index ca3696d82ff1df79a2751fc7f4410f4a840a453a..44656ffe996443f5ea3249fe5a32b72bc2c89e39 100644 (file)
@@ -5,23 +5,23 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
-define Profile/CAS-771
+define Profile/CAS771
        NAME:=Cellvision CAS-771 IP camera
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
        NAME:=Cellvision CAS-771 IP camera
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
-define Profile/CAS-771/Description
+define Profile/CAS771/Description
        Package set optimized for the Cellvision CAS-771 device.
 endef
 
        Package set optimized for the Cellvision CAS-771 device.
 endef
 
-define Profile/CAS-771W
+define Profile/CAS771W
        NAME:=Cellvision CAS-771W IP camera
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500
 endef
 
        NAME:=Cellvision CAS-771W IP camera
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500
 endef
 
-define Profile/CAS-771W/Description
+define Profile/CAS771W/Description
        Package set optimized for the Cellvision CAS-771W device.
 endef
 
        Package set optimized for the Cellvision CAS-771W device.
 endef
 
-$(eval $(call Profile,CAS-771))
-$(eval $(call Profile,CAS-771W))
+$(eval $(call Profile,CAS771))
+$(eval $(call Profile,CAS771W))