tools: add isl (used for graphite on GCC 5)
authorFelix Fietkau <nbd@openwrt.org>
Fri, 13 Nov 2015 11:35:37 +0000 (11:35 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 13 Nov 2015 11:35:37 +0000 (11:35 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47464

toolchain/gcc/Config.in
tools/Makefile
tools/isl/Makefile [new file with mode: 0644]

index 81b795edd0e98f9fd144a2a92cc929f028a5e5f1..249a01b5095dee24cac9545f5faf850ab576f00b 100644 (file)
@@ -32,7 +32,7 @@ config GCC_USE_GRAPHITE
 config GCC_USE_SYSTEM_PPL_CLOOG
        bool
        prompt "Use the system versions of PPL and CLooG"
 config GCC_USE_SYSTEM_PPL_CLOOG
        bool
        prompt "Use the system versions of PPL and CLooG"
-       depends on GCC_USE_GRAPHITE
+       depends on GCC_USE_GRAPHITE && GCC_VERSION_4_8
        default n
 
 config EXTRA_GCC_CONFIG_OPTIONS
        default n
 
 config EXTRA_GCC_CONFIG_OPTIONS
index df384d4a9076f6b9b18c322fd36bb6b04be72173..346f0e9f389410af07bd71b6ffb3004b0e609905 100644 (file)
@@ -13,10 +13,14 @@ tools-y :=
 
 ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
   BUILD_TOOLCHAIN := y
 
 ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
   BUILD_TOOLCHAIN := y
-endif
-ifdef CONFIG_GCC_USE_GRAPHITE
-  ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
-    BUILD_PPL_CLOOG = y
+  ifdef CONFIG_GCC_USE_GRAPHITE
+    ifneq ($(CONFIG_GCC_VERSION_4_8),)
+      ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
+        BUILD_PPL_CLOOG = y
+      endif
+    else
+      BUILD_ISL = y
+    endif
   endif
 endif
 ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),)
   endif
 endif
 ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),)
@@ -37,6 +41,7 @@ tools-$(CONFIG_TARGET_ar71xx) += lzma-old squashfs
 tools-y += lzma squashfs4
 tools-$(BUILD_B43_TOOLS) += b43-tools
 tools-$(BUILD_PPL_CLOOG) += ppl cloog
 tools-y += lzma squashfs4
 tools-$(BUILD_B43_TOOLS) += b43-tools
 tools-$(BUILD_PPL_CLOOG) += ppl cloog
+tools-$(BUILD_ISL) += isl
 tools-$(CONFIG_USE_SPARSE) += sparse
 
 # builddir dependencies
 tools-$(CONFIG_USE_SPARSE) += sparse
 
 # builddir dependencies
@@ -67,6 +72,7 @@ $(curdir)/sdcc/compile := $(curdir)/bison/install
 $(curdir)/b43-tools/compile := $(curdir)/bison/install
 $(curdir)/padjffs2/compile := $(curdir)/findutils/install
 $(curdir)/cloog/compile := $(curdir)/ppl/install
 $(curdir)/b43-tools/compile := $(curdir)/bison/install
 $(curdir)/padjffs2/compile := $(curdir)/findutils/install
 $(curdir)/cloog/compile := $(curdir)/ppl/install
+$(curdir)/isl/compile := $(curdir)/gmp/install
 $(curdir)/bc/compile := $(curdir)/bison/install
 $(curdir)/findutils/compile := $(curdir)/bison/install
 $(curdir)/gengetopt/compile := $(curdir)/libtool/install
 $(curdir)/bc/compile := $(curdir)/bison/install
 $(curdir)/findutils/compile := $(curdir)/bison/install
 $(curdir)/gengetopt/compile := $(curdir)/libtool/install
diff --git a/tools/isl/Makefile b/tools/isl/Makefile
new file mode 100644 (file)
index 0000000..8fe2da1
--- /dev/null
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=isl
+PKG_VERSION:=0.14.1
+
+PKG_SOURCE_URL:=http://isl.gforge.inria.fr
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=94fcd11e0b1c79250ae341affb1845ea
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-gmp-prefix=$(STAGING_DIR_HOST)
+
+$(eval $(call HostBuild))