Update shell-fm to 0.5 (#3614)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 27 Jul 2008 12:02:54 +0000 (12:02 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 27 Jul 2008 12:02:54 +0000 (12:02 +0000)
SVN-Revision: 11956

sound/shell-fm/Makefile
sound/shell-fm/patches/001-cross_compile.patch [new file with mode: 0644]
sound/shell-fm/patches/002-wifcontinued.patch [new file with mode: 0644]

index 5819d693a9a322839c632accb49c0bc317977156..ea73b03bb1ead6fdd90e1b08806fd8a5be783e73 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shell-fm
-PKG_VERSION:=0.2
-PKG_RELEASE:=2
+PKG_VERSION:=0.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://nex.scrapping.cc/shell-fm/downloads
-PKG_MD5SUM:=6ebbcf1af241a92a1237547fc39ca728
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://nex.scrapping.cc/code/shell-fm/downloads/
+PKG_MD5SUM:=a257283b0f7e9173ee1073b88e57c5f6
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -39,19 +36,20 @@ define Package/shell-fm/conffiles
 endef
 
 define Build/Configure
-       $(PKG_BUILD_DIR)/reconfig
-       $(call Build/Configure/Default, --disable-ao)
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -I./include/ -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lmad -lao" \
                all install
 endef
 
 define Package/shell-fm/install        
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/shell-fm $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/shell-fm $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/shell-fm.rc $(1)/etc/shell-fm.rc
        $(INSTALL_DIR) $(1)/etc/init.d
diff --git a/sound/shell-fm/patches/001-cross_compile.patch b/sound/shell-fm/patches/001-cross_compile.patch
new file mode 100644 (file)
index 0000000..00e1953
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN shell-fm-0.5/source/Makefile shell-fm-0.5.new/source/Makefile
+--- shell-fm-0.5/source/Makefile       2008-04-10 22:27:28.000000000 +0200
++++ shell-fm-0.5.new/source/Makefile   2008-07-26 21:00:48.000000000 +0200
+@@ -9,7 +9,7 @@
+ .PHONY: clean
+ shell-fm      : $(OBJECT)
+-      gcc -o $(BINARY) $(CFLAGS) $(OBJECT) $(shell pkg-config mad --libs) $(LDFLAGS)
++      $(CC) -o $(BINARY) $(CFLAGS) $(OBJECT) $(shell pkg-config mad --libs) $(LDFLAGS)
+ clean         :
+       rm -f $(OBJECT) $(BINARY)
diff --git a/sound/shell-fm/patches/002-wifcontinued.patch b/sound/shell-fm/patches/002-wifcontinued.patch
new file mode 100644 (file)
index 0000000..7a12ce4
--- /dev/null
@@ -0,0 +1,13 @@
+--- shell-fm-0.5/source/main.c 2008-04-10 22:27:28.000000000 +0200
++++ shell-fm-0.5.new/source/main.c     2008-07-27 13:50:43.000000000 +0200
+@@ -33,6 +33,10 @@
+ #define PATH_MAX 4096
+ #endif
++#ifndef WIFCONTINUED 
++#define WIFCONTINUED(wstat)   (0) 
++#endif 
++
+ unsigned flags = RTP;
+ time_t changeTime = 0, pausetime = 0;
+ char * nextstation = NULL;