build: do another init script enabling run, fixes init scripts added via files/ ...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jun 2015 17:42:05 +0000 (17:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jun 2015 17:42:05 +0000 (17:42 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45964

package/Makefile

index a601dcbb31bb31c2e73ffe428aee1c0c9942a168..5fb7363bc92558a7cebb4c685607ede90979dc04 100644 (file)
@@ -111,6 +111,10 @@ $(curdir)/install: $(TMP_DIR)/.build
                cd $(TARGET_DIR); \
                for script in ./usr/lib/opkg/info/*.postinst; do \
                        IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) $$script; \
+               done; \
+               for script in ./etc/init.d/*; do \
+                       grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
+                       IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) ./etc/rc.common $$script enable; \
                done || true \
        )
        @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf