[backfire] toolchain: fix paths after relocation from usr/ (#10876)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 30 Jan 2012 21:48:23 +0000 (21:48 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 30 Jan 2012 21:48:23 +0000 (21:48 +0000)
SVN-Revision: 29961

target/toolchain/Makefile

index 1e0dec2dd1076bbec82f2697385e99e83b3a33d6..0db18d1ac1bcb12f628272c3b3fcf7d0e761314f 100644 (file)
@@ -38,9 +38,9 @@ $(BIN_DIR)/$(TOOLCHAIN_NAME).tar.bz2: clean
        $(CP)  $(TOPDIR)/LICENSE ./files/README.TOOLCHAIN \
                $(TOOLCHAIN_BUILD_DIR)/
 
-       $(CP) ./files/wrapper.sh $(TOOLCHAIN_PREFIX)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
-       chmod +x $(TOOLCHAIN_PREFIX)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
-       (cd $(TOOLCHAIN_PREFIX)/usr/bin; \
+       $(CP) ./files/wrapper.sh $(TOOLCHAIN_PREFIX)/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
+       chmod +x $(TOOLCHAIN_PREFIX)/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
+       (cd $(TOOLCHAIN_PREFIX)/bin; \
                for app in cc gcc g++ c++ cpp ld as ; do \
                        [ -f $(REAL_GNU_TARGET_NAME)-$${app} ] && mv $(REAL_GNU_TARGET_NAME)-$${app} $(REAL_GNU_TARGET_NAME)-$${app}.bin ; \
                        ln -sf $(REAL_GNU_TARGET_NAME)-wrapper.sh $(REAL_GNU_TARGET_NAME)-$${app} ; \