[include] autotools.mk: remove GNUmakefile before running autoreconf (spotted libgcry...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 8 Dec 2010 11:55:41 +0000 (11:55 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 8 Dec 2010 11:55:41 +0000 (11:55 +0000)
SVN-Revision: 24344

include/autotools.mk

index 9ba3fc33b9e901a1e8fe80ef18094c6cab0c2264..a1a5d5d81521f29f194dfadb7e1acec3b694af52 100644 (file)
@@ -20,6 +20,7 @@ define autoreconf
                if [ -x ./autogen.sh ]; then \
                        ./autogen.sh || true; \
                elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
                if [ -x ./autogen.sh ]; then \
                        ./autogen.sh || true; \
                elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+                       rm -f ./GNUmakefile; \
                        $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
                                $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
                fi \
                        $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
                                $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
                fi \