[packages] coova-chilli: support mac password function in config script again (#6630)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 3 Feb 2010 22:07:50 +0000 (22:07 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 3 Feb 2010 22:07:50 +0000 (22:07 +0000)
SVN-Revision: 19508

net/coova-chilli/Makefile
net/coova-chilli/patches/001-readd-macauth.patch [new file with mode: 0644]

index 692cd44ca2b758c303359d4d550ccb8afb3e2454..4d6919b120994cff9e6d9a8c808337c508310d7f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coova-chilli
-PKG_VERSION:=1.2.1
-PKG_RELEASE:=1
+PKG_VERSION:=1.0.14
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ap.coova.org/chilli/
-PKG_MD5SUM:=f4c0cdb903b6a830cd7c8a54db2334e8
+PKG_MD5SUM:=88774ec55f9943d174ea7dd26e85fd8a
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/net/coova-chilli/patches/001-readd-macauth.patch b/net/coova-chilli/patches/001-readd-macauth.patch
new file mode 100644 (file)
index 0000000..c6d3620
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/conf/functions.in
++++ b/conf/functions.in
+@@ -153,6 +153,7 @@
+     if [ "x$HS_RADCONF" != "xon" -a "x$HS_RADCONF" != "xurl" ]; then 
+       [ "$HS_PAP_OK" = "on" ] && addconfig2 "papalwaysok"
+       [ "$HS_MACAUTH" = "on" ] && addconfig2 "macauth"
++      [ "$HS_MACAUTH" = "on" -a -n "$HS_MACPASSWD" ] && addconfig2 "macpasswd $HS_MACPASSWD"
+       [ "$HS_MACREAUTH" = "on" ] && addconfig2 "macreauth"
+       [ "$HS_MACAUTHDENY" = "on" ] && addconfig2 "macauthdeny"
+       [ "$HS_WPAGUESTS" = "on" ] && addconfig2 "wpaguests"